Go Back   Mitsubishi Forum - Mitsubishi Enthusiast Forums > Mitsubishi Models > Mitsubishi Eclipse & Eclipse Spyder > 2nd Generation
Sign in using an external account
Register Forgot Password?
Search

Welcome to the Mitsubishi Forum - Mitsubishi Enthusiast Forums.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-19-2009, 01:56 PM
Junior Member
 
Join Date: Jul 2009
Posts: 2
Unhappy 97 eclipse gst No Overdrive

I have a 97 eclipse GST. It's an automatic and the overdrive doesn't kick in. When I push the overdrive button, it doesn't engage and feels like it's in neutral. Someone told me it could be the relay or sensor. I would like to know if this is the problem.. If so, I need to know where the relay or sensor is located. Any help will be greatly appreciated.
This ad is not displayed to registered members.
Register your free account today and become a member on MitsubishiForum!
Reply With Quote
Old 07-19-2009, 01:56 PM
 
 
 
Reply

Tags
97, 99, automatic, button, eclips, eclipse, gst, gts, misubishi, od, overdrive, problem, problems, sensor, speed, spyder, stuck, work


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 08:58 PM.

Internet Brands, Inc.