Go Back   Mitsubishi Forum - Mitsubishi Enthusiast Forums > Tech Help and Information > Everything else
Sign in using an external account
Register Forgot Password?
Search

Welcome to the Mitsubishi Forum - Mitsubishi Enthusiast Forums.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-22-2005, 01:33 AM
 
Join Date: Apr 2005
Posts: 5
Default help I tried everything! High idle


95 Talon Tsi

Everything runs fine, strong boost, smooth idle on cold start... except sometimes an anomoly occurs, which I think i've narrowed down to happening only when I've driven it 10 miles or so, turn the car off, then start it again. The idle rises when i start the engine to 1100 rpm, then it'll climb to 1500 ish, then it will rev itself between 1200 and 1500 up and down, up and down, up and down. Sometimes it will just idle at 2800 to 3000rpm. When I start the car cold, the idle is nice and crisp staying at around 750 -800. I can drive it for almost an hour straight with no problems. Cannon ball runs down the highway, stop at an off ramp and it sticks at 750 like that's it's job. But i turn the car off to go into the store, and when i turn it on again, the idle starts doing it's thing again. At least it's not doing the annoying up down thing first thing each morning.

Checked all the vaccume lines, as much as i can see, and everything looks like it's in shape. Took it to advance auto for the free code scan service. Scanner said P0505 Idle Control System Malfunction. They kept saying they think it's the TPS I thought no kidding! Opened the haynes manual, it says the code P0505 means IAC Valve System Fault. So i went to the junkyard and snagged a new-to-me IAC Valve. I swapped it in and turned on the car. It started and immediately idled a little low and a little bumpy like it was choking for air. Then I thought to unhook the battery terminals for 15 min to reset the computer and let it calibrate itself. Hooked them back up and started the engine again. Up down, up down choke choke, .... at this point i thought WTF!? Then i tried to listen for the IAC Valve motor make sound like the manual says while an assistant turns the ignition on and off without starting the engine. Each time i heard it make more and more movement. Finally after enough on and offs it sounded like it had worked it's kinks out. Started the engine and it worked like a charm. Mabee it calibrated itself? Dunno but I thought it was fixed. Went to the store, came back to the car and turned it on..... high idle thing again. Very frustrated at this point. TPS? IAC still bad? PCM?

Ideas?
This ad is not displayed to registered members.
Register your free account today and become a member on MitsubishiForum!
Reply With Quote
  #2  
Old 04-23-2005, 06:50 AM
Senior Member
 
Join Date: Nov 2004
Location:
Posts: 207
Send a message via AIM to DragonRacerX666
Default RE: help I tried everything! High idle

it idling high at first is only because its cold but, the reving up and down thing is because of the IAC.

I need one too if you know where i can get one cheap.
__________________
Watching people getting owned = Priceless
Reply With Quote
  #3  
Old 04-23-2005, 08:41 PM
 
Join Date: Apr 2005
Posts: 5
Default RE: help I tried everything! High idle

Well don't try what i did which was go to the junk yard and pull one off of a 2.0L non-turbo when you have a 2.0L Turbo. 2 days later after driving it, the burning electronics smell came back. Only this time i was driving. All of a sudden the engine shut off instantaneously and i coasted into a parkinglot never to start the engine again. Now I'm trying to figure out what is fried and i'm up **** creek. Anyone have any ideas? Put my ODBII code puller on it and it now just pulls P0505 which is IAC Valve Failure. Does that mean the ECU works still?
Reply With Quote
  #4  
Old 04-24-2005, 05:42 AM
Senior Member
 
Join Date: Nov 2004
Location:
Posts: 207
Send a message via AIM to DragonRacerX666
Default RE: help I tried everything! High idle

I did that samething but, i pulled mine from a 2001 eclipse... but the IAC was damaged so, rebuilt mine by mixing a few parts with the old thinking it would fix it till i discovered what goes wrong with them when it does the reving up and down thing... that plastic piece gets worn out and loose so you can make it agitate and thats why it does it but, I think you have a totaly different problem.

I have a 91 eagle talon TSI and i used a 2001 eclipse IAC...

You might want to check some wiring or something.
__________________
Watching people getting owned = Priceless
Reply With Quote
  #5  
Old 04-24-2005, 06:12 PM
 
Join Date: Apr 2005
Posts: 5
Default RE: help I tried everything! High idle

Quick update on the situation. After using an IAC Valve from a 91 - 92 non turbo, the car is incapacitated and the interior smells of burning electronics. I was reading the haynes manual for the car and it mentioned that the IAC controls the idle via the PCM (powertrain control module). So I found where it is located and could smell i was getting closer to the answer while taking the unit out. I opened it up and PHEW! there's a big problem with the unit. It had a meltdown. So I'm trying to figure out what other years and models fit my 95 talon 2.0L turbo. Does anyone know what other years are compatable? Turbo, non-turbo?

Reply With Quote
Old 04-24-2005, 06:12 PM
 
 
 
Reply

Tags
2002, 99, control, diamante, eagle, eclipse, fit, high, iac, idle, idles, lancer, malfunction, mitsubishi, p0505, problems, start, system, talon


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 04:51 AM.

Internet Brands, Inc.