Go Back   Mitsubishi Forum - Mitsubishi Enthusiast Forums > Mitsubishi Models > Mitsubishi Galant
Sign in using an external account
Register Forgot Password?
Search

Welcome to the Mitsubishi Forum - Mitsubishi Enthusiast Forums.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-30-2012, 05:49 AM
Junior Member
 
Join Date: Jul 2012
Location: Lancaster, UK
Posts: 2
Default 01 Galant Electronic Fuel Injection Module Failed?

Hi everybody!

I am in hope that some of you could help me out a little. Starting with the details:

Car: Mitsubishi Galant 2001
Engine: 4G94 GDI 2.0L
Modifications: NONE

Pre-incident the car run fine, I drove about 250 miles in 1 day and then parked it overnight. Next morning it started and wanted to stall immideiatley, with no response to adding throttle. I turned it off, and then back on and the problem went away. Next day It threw a code at me P0500, I pulled it and it was: Random Multiple Missfire, which went away after a 1.5 mile drive. Since then when the engine is cold it stalls, and when warmed up the idle is very rough, no more fault codes.

I think I narrowed it down to a problem with the fuel injectors. Cylinder 2 & 3 are not firing as they are not receiving any fuel. I checked the injectors and they are in good working order, the injector harness/wire is also good and tested. I changed the spark plugs and all cylinders are getting a good spark.

My problem is that the fuel injectors 2 & 3 are not receiving a signal from the control module. This is what i think, however I maybe wrong. Would like to hear your opinion on any other possibility. As I understand this can end up being very expensive.

I have had a hard time trying to find the electrical diagram for the car, so if anyone has one and can share that would be great! I traced the wire to the module and it seems like it sits under the Air Intake and directly under the Air Filter. I was also told that module "Pairs Cylinders 1&4 - 2&3" so it only has 2 connections to it. So if it is the module and if only 1/2 of it failed, is there a chance for a repair/rebuild? Or is buying a new one the only option.

Looking for your inputs, and anything else that I can check. Hoping that the problem is easily solved!

Thanks!
This ad is not displayed to registered members.
Register your free account today and become a member on MitsubishiForum!
Reply With Quote
Old 07-30-2012, 05:49 AM
 
 
 
Reply

Tags
cylinder, efi, electronic, firing, fuel, galant, gdi, injector, injectors, mitsubishi, problem, response, throttle, ticking, yoi


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 03:23 AM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.