Go Back   Mitsubishi Forum - Mitsubishi Enthusiast Forums > Mitsubishi Models > Mitsubishi Galant
Sign in using an external account
Register Forgot Password?
Search

Welcome to the Mitsubishi Forum - Mitsubishi Enthusiast Forums.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-10-2005, 04:24 PM
 
Join Date: Oct 2005
Posts: 4
Default Galant ES, Engine Stalls at Idle, 4cyl SOHC

Hello,
I have a 2000 Mitsubishi Galant ES with 4cyl, SOHC engine with 79,000 miles

It stalls while idling but only while warming up as I will describe here. It idles fine for the first couple of minutes after starting with a cold engine. Then stalls while idling for about the next 10-15 minutes. Then after a while idles fine again. Otherwise engine runs very smooth at all speeds, except stalls at idle as described above. I can keep the engine from stalling at idle by pressing gas pedal slightly to keep RPM's to just under 1,000. Also, when engine stalls it is smooth, no jerky motion from engine. It's as if someone turned off the key.

Engine always starts immediately when starter engaged (at any time).

No OBD / DTC codes set. Spark plugs and air filter replaced ~6mos ago with no problems until this week. Has integrated fuel pump filter that factory says should not need to be changed.

I live in coastal San Diego with a very mild climate. Outdoor temperatue in 70's F.

Does anyone have any ideas on diagnosing? Any suggestions would be greatly appreciated.

Robert
This ad is not displayed to registered members.
Register your free account today and become a member on MitsubishiForum!
__________________
Robert
Reply With Quote
  #2  
Old 12-15-2005, 08:31 PM
 
Join Date: Oct 2005
Posts: 77
Default RE: Galant ES, Engine Stalls at Idle, 4cyl SOHC

Dude, the 2g Eclipse have the same problem.......its your idle motor. (IDLE AIR CONTROL MOTOR)
Reply With Quote
  #3  
Old 12-29-2007, 07:53 PM
 
Join Date: Oct 2005
Posts: 4
Default RE: Galant ES, Engine Stalls at Idle, 4cyl SOHC

Last time (see above) I had this idle stalling problem the car started running great by itself after a few days. I suspect the computer adjusted and compensated for the problem. Recently, the battery got drained again. Once I resolved the battery problem, the car would not idle after warming up. It would idle cold and then after it warmed up it would stall every time at idle speeds. I tried the same approach as last time and drove it for a couple of days but the stalling continued.

I looked again all over the Internet and found all sorts of complicated and expensive solutions. Most of them were to start replacing parts without testing for broken parts. However, for troubleshooting I usually try the simple fixes first. I found a great comment from "galant2000" at http://www.automotiveforums.com/vbulletin/t295165.html. The inside of the throttle body had black gunk just as described by "galant2000".

I simply cleaned the throttle body and the car now runs/idles great. I followed the directions in my Haynes shop manual. I used a throttle body cleaner on a rag to wipe off the black gunk. The manual says to be sure to cleaner that is compatible with oxygen sensors and catalytic converters (says so on the can). The manual also says to be sure to NOT clean the Throttle Position sensor or Idle Air Control motor. It also says careful not to get the cleaner or any other debris in the two square holes at the bottom of the throttle body. I just carefully plugged these holes with a clean rag and put the cleaner on another rag and wiped all the black gunk out. This took less than half an hour.

I hope this helps.

Robert

__________________
Robert
Reply With Quote
  #4  
Old 12-29-2007, 10:24 PM
Banned
 
Join Date: Feb 2006
Location: Austin, TX
Posts: 16,203
Send a message via AIM to Sebba Send a message via Yahoo to Sebba
Default RE: Galant ES, Engine Stalls at Idle, 4cyl SOHC

Dude... look at the date
Reply With Quote
  #5  
Old 12-30-2007, 06:14 PM
 
Join Date: Oct 2005
Posts: 4
Default RE: Galant ES, Engine Stalls at Idle, 4cyl SOHC

I don't see the point of your comment? I know the date. I posted the original. The new comments still apply and may help someone with what appears to be a common problem.
__________________
Robert
Reply With Quote
  #6  
Old 12-30-2007, 08:02 PM
Banned
 
Join Date: Feb 2006
Location: Austin, TX
Posts: 16,203
Send a message via AIM to Sebba Send a message via Yahoo to Sebba
Default RE: Galant ES, Engine Stalls at Idle, 4cyl SOHC

Its2 years old man... just kinda usless
Reply With Quote
  #7  
Old 12-31-2007, 10:25 AM
 
Join Date: Oct 2005
Posts: 4
Default RE: Galant ES, Engine Stalls at Idle, 4cyl SOHC

"Dude", Speaking of kinda useless. What value did your comments add???

I have a couple of comments:
- First in the future I would recommend that you actually read a post and understand it before you reply to it. This problem just happened last week. And it is still very relevant.
- Second, unless every Mitsubishi with the same throttle body has magically disappeared or suddenly has a newly adopted throttle body cleaning genie then my posting is completely applicable (even right now, even in a year from now) to anyone who may have a similar problem. It could save them time, money, and hassle. Guess what? Other people may have the same problem and could be helped by my latest posting. I suppose that trying to thank this forum for help in the past by posting a followup is too complicated for you. Are you really that simple?

__________________
Robert
Reply With Quote
  #8  
Old 12-31-2007, 03:17 PM
Banned
 
Join Date: Feb 2006
Location: Austin, TX
Posts: 16,203
Send a message via AIM to Sebba Send a message via Yahoo to Sebba
Default RE: Galant ES, Engine Stalls at Idle, 4cyl SOHC

I understand what your saying. Do you understand my point though?
Reply With Quote
  #9  
Old 01-18-2008, 01:34 PM
Senior Member
 
Join Date: Nov 2006
Location:
Posts: 325
Default RE: Galant ES, Engine Stalls at Idle, 4cyl SOHC

Anytime the battery goes dead or is replaced you need to clean the Throttle Body. With a new battery the ECU thinks it has a clean TB and does not adjust for the carbon build up. Clean it with some Throttle Body cleaner (not Carbaratorcleaner or Brake cleaner)and a rag. After cleaning disconnect the battery for a few minutes. After that it should run and idle fine. If not it is probably the idle speed control motor.
__________________
06 Raider XLS Lava Red V-8 2WD 4DR
-AEM Brute Force Intake
-Front Tow Hooks
-Spray in bed liner
Reply With Quote
  #10  
Old 01-07-2009, 10:03 AM
 
Join Date: Jan 2009
Posts: 2
Default RE: Galant ES, Engine Stalls at Idle, 4cyl SOHC

Wow, this is great. I am having this exact problem, and I will try your solution first by cleaning the throttle body of gunk. If this works, your a life saver.

Jim in Kansas City
Reply With Quote
Old 01-07-2009, 10:03 AM
 
 
 
Reply

Tags
05, 2000, 2005, 95, air, es, flow, galant, idle, mass, replace, sensor, speed, stalling, stalls, troubleshooting


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 10:19 PM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.