Go Back   Mitsubishi Forum - Mitsubishi Enthusiast Forums > Mitsubishi Models > Mitsubishi Galant
Sign in using an external account
Register Forgot Password?
Search

Welcome to the Mitsubishi Forum - Mitsubishi Enthusiast Forums.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #11  
Old 02-20-2008, 06:21 PM
 
Join Date: Feb 2008
Location:
Posts: 133
Default RE: Turn Signal and Hazard Lights not working!!!

doesnt sound like you're going to have a choice in the matter. and once they tell you what it is you're going to feel silly, because it's always somthing silly
This ad is not displayed to registered members.
Register your free account today and become a member on MitsubishiForum!
__________________

Reply With Quote
  #12  
Old 02-21-2008, 01:34 PM
 
Join Date: Feb 2008
Posts: 13
Default RE: Turn Signal and Hazard Lights not working!!!

Things got worse. My father-in-law was checking it out. I don't know what he did but he stuck a probe in the hazard light fuse and all the light on the car turned on. I had to disconnect my battery to shut the damn things off!!!
Reply With Quote
  #13  
Old 02-22-2008, 12:51 AM
Senior Member
 
Join Date: Feb 2008
Location: houma, louisianna
Posts: 346
Default RE: Turn Signal and Hazard Lights not working!!!

hello! you have pinched a harness in the radio area and several wires have been cut and are shorted to ground. take out the radio and faceplate. get a bright light and shine it in there. grab each harness in there and inspect VERY carefully. to blow that many different fusesseveral wires have been cut, pinched, ect.. when you put the stereo in did a harness get in between the radio and the bracket that it mounts too?? that is usually what happens. look carefully!! good luck!! keep us posted!
Reply With Quote
  #14  
Old 02-24-2008, 02:56 PM
 
Join Date: Feb 2008
Posts: 13
Default RE: Turn Signal and Hazard Lights not working!!!

[sm=happybounce.gif]I finally found the problem.I had to take the right fender off. underneath it are all the wires that lead into the cabin. There I found a mess of melted wires all caused by years of water and ice and dirt deteriorating the wire protection.Re-wire the bad wires and my car is as good as new.
Reply With Quote
  #15  
Old 02-24-2008, 06:14 PM
Senior Member
 
Join Date: Oct 2006
Location: Calexico, CA
Posts: 1,835
Send a message via Yahoo to Kaede.Noir
Default RE: Turn Signal and Hazard Lights not working!!!

oh my god... who would have thought of so.... now you got me thinking..... im gonna go ahead and check on mine as well...
__________________
"In life you only have 2 choices... you can choose to be happy... or not"
Reply With Quote
Old 02-24-2008, 06:14 PM
 
 
 
Reply

Tags
2007, galant, good, hazard, lamp, lancer, light, mitsubishi, montero, raider, rear, relay, signal, signals, switch, turn, turnsignal, working


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 03:38 AM.

Internet Brands, Inc.