Go Back   Mitsubishi Forum - Mitsubishi Enthusiast Forums > Tech Help and Information > Suspension
Sign in using an external account
Register Forgot Password?
Search

Welcome to the Mitsubishi Forum - Mitsubishi Enthusiast Forums.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-21-2007, 04:43 AM
 
Join Date: Feb 2007
Posts: 1
Default Squeaking Sound???

I have a 2000 Eclipse GT, and im getting a squeaking noise from the front end... (When I accelerate/slow down)
Anyone out there know what this is? Somewhere in the suspension, but dont know where to start....
Thanks in advance for any help!!!!
This ad is not displayed to registered members.
Register your free account today and become a member on MitsubishiForum!
Reply With Quote
  #2  
Old 02-22-2007, 07:42 AM
 
Join Date: Apr 2006
Location: Tampa, Florida
Posts: 363
Send a message via AIM to WPSpyderGT01 Send a message via Yahoo to WPSpyderGT01
Default RE: Squeaking Sound???

if your getting it on the front end of the passenger side... ill put my money on that its your passenger side motor mount.. the 3g passenger side motor mounts are known to give out really really quick.
__________________
Reply With Quote
  #3  
Old 02-26-2007, 02:59 PM
 
Join Date: Aug 2005
Posts: 34
Default RE: Squeaking Sound???

if u have a cold air intake with air filter in the fender...in a lot of mitsubishis its hard to fit them because of the battery...On my lancer, the battery was pushing a side of the pipe onto an engine bolt....cutting into causing a squeeking nooise
__________________
~ CAM
Reply With Quote
  #4  
Old 03-03-2007, 08:15 AM
 
Join Date: Apr 2006
Location: Tampa, Florida
Posts: 363
Send a message via AIM to WPSpyderGT01 Send a message via Yahoo to WPSpyderGT01
Default RE: Squeaking Sound???

loud noises when you acc or brake.. or turn... on the passenger side.. will be that motor mount.. and if he has a cold air intake.. that would be located on the driver side

i had the same problems but upgrade my motor mounts to solid and flex
__________________
Reply With Quote
  #5  
Old 12-07-2008, 08:22 PM
 
Join Date: Nov 2008
Posts: 2
Default RE: Squeaking Sound???

hey guys, i have a 2003 eclipse gts and i have the same exact problem and its really starting to annoy me. Im getting my timing belt replaced in a few weeks, about how much extra do you think it would cost to have my motor mounts replaced while they do that?
Reply With Quote
  #6  
Old 12-18-2008, 04:36 PM
dsm1990gsx's Avatar
Super Moderator
 
Join Date: Oct 2007
Location: Pottstown, Pa
Posts: 4,694
Default RE: Squeaking Sound???

Check the dates before you post.
__________________
2004 Ford Escape Xlt
2001 Mercury Sable
1990 Tsi Awd 12.8 @110 s16g @ 22lbs 2.0 60 ft.
-13.3 @114 holset hx35 @ 20lbs *needs new driver mod
1992 galant vr4
Reply With Quote
Old 12-18-2008, 04:36 PM
 
 
 
Reply

Tags
2000, 2006, eclipse, end, front, gt, mitsubishi, montero, passenger, side, sound, sport, squeak, squeaking, squeking


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 11:16 AM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.