Mitsubishi Forum - Mitsubishi Enthusiast Forums

Mitsubishi Forum - Mitsubishi Enthusiast Forums (https://mitsubishiforum.com/forum/)
-   Mitsubishi Galant (https://mitsubishiforum.com/forum/mitsubishi-galant-13/)
-   -   05 Galant 2.4 4G69 timing issues (https://mitsubishiforum.com/forum/mitsubishi-galant-13/05-galant-2-4-4g69-timing-issues-46448/)

slyfoxninja 05-06-2014 03:35 PM

05 Galant 2.4 4G69 timing issues
 
My brother broke his timing belt on his 05 Galant 2.4 4G69. I've replaced everything that needed to be swapped out; the marks are dead on and the engine won't turn over. The engine cranks, but just doesn't fire. I'm afraid it's a valve, but I haven't done a compression check yet to verify. The first time I started it ran like crap; I checked the marks and the cam was off about a tooth maybe a tooth and half. I realigned everything even the stupid oil pump gear that likes to jump a tooth when you put tension to it. I'm exhausted and out of ideas. Any 3rd party ideas would be very grateful.

Thanks, Mark

Mathularan 05-31-2014 06:01 AM

If you align the crank to the top dead center by the time you tighten it up and rotate it around a few times it'll jump time about 3/8 of an inch to the right, so you should set it to about 3/8 of an inch to the left of the timing mark, then you can tighten it up and when you wind it up a few times and put it back to top dead center it should be aligned perfectly.

Hope this helps :3

2001Mitch3.5XS 05-31-2014 09:03 AM

Be sure your on the intake stroke and not the Exhaust stroke and Good Luck.


All times are GMT -5. The time now is 11:55 PM.


© 2019 MH Sub I, LLC dba Internet Brands