Mitsubishi Galant A sporty mid-sized sedan offering the perspective buyer a change from the normal mid-size sedan class.

Does anyone know what causes this??

  #1  
Old 05-10-2004, 07:56 PM
Thread Starter
Join Date: Apr 2004
Location: United States
Posts: 1
Default Does anyone know what causes this??

<FONT face="Arial, Helvetica, sans-serif">I have a 2000 mits galant that I bought used and ever since I got it when I go over 65mph my front end vibrates. I have had alignment after alignment, new tires, and tires balanced. Does anyone know what causes this?</FONT>
 
  #2  
Old 05-11-2004, 10:36 AM
Join Date: May 2004
Location: United States
Posts: 9
Default Does anyone know what causes this??

<FONT color=blue face="Courier New, Courier, mono" size=3>It could be one of two things if not both, One: you might need to replace one of the Tie Rods if not all 4 (hope not) or the tires need to be rotated. If it is not one of the two than I really wouldn't know what else could it be.</FONT>
 
  #3  
Old 05-18-2004, 01:36 AM
Join Date: Jan 2004
Location: United States
Posts: 68
Default Does anyone know what causes this??

bent rim ,, out of round front rotors , bad wheel bearing , shifted belt in tire, ball joints bad ( bottom) tie rods bad, take it to a good shop and have them check the front NOT PEP BOYS or equivilent NTW , or any good tire place
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
underpressure2003
Mitsubishi 3000GT
1
08-20-2007 01:53 AM
dreamz
2nd Generation
21
01-04-2006 02:44 AM
martinez7
Mitsubishi Endeavor
0
07-02-2005 07:05 PM
XLR8N_GSX
2nd Generation
2
12-19-2003 06:56 AM


Thread Tools
Search this Thread
Quick Reply: Does anyone know what causes this??


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.