Mitsubishi Forum - Mitsubishi Enthusiast Forums - Search Results

Search: Posts Made By: robertzkielc
Showing results 1 to 5 of 5
Search took 0.00 seconds.
05-25-2015, 02:11 AM
Replies: 1
Views: 821
Posted By robertzkielc

Follow up

Well it looks like the problem was 6 months old distributor with cap, not sure which one but since they came as a set they both got replaced with new one and it seems so far that all is good :).
05-15-2015, 01:34 PM
Replies: 1
Views: 821
Posted By robertzkielc

96 Galant shutting down on highway

Have 96' Galant S with 235k miles. It had 60k major service done just 2k miles ago. It developed new problem: engine shutting off at highway speeds between 65 and 70 miles an hour and mostly on...
08-19-2014, 02:29 AM
Replies: 2
Views: 1,241
Posted By robertzkielc

Hi Reynard I have 1996 Galant with 218k miles...

Hi Reynard
I have 1996 Galant with 218k miles on it and when doing 60k service always do: timing belt and auxiliary belts, water pump, spark plugs with wires, distributor, engine and transmission...
07-23-2014, 02:22 AM
Replies: 1
Views: 420
Posted By robertzkielc

Follow up. It wasn't the front pipe but instead...

Follow up.
It wasn't the front pipe but instead it was bad timing on crankshaft. All good and quiet now.
07-16-2014, 03:09 PM
Replies: 1
Views: 420
Posted By robertzkielc

1996 Galant front pipe issue

HI
I have 1996 Galant California version, only state that forced Mits to make special changes to exhaust system, like having 2 catalytic converters. It had a flex pipe replaced that sits in the...
Showing results 1 to 5 of 5


 
Forum Jump

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.