Go Back   Mitsubishi Forum - Mitsubishi Enthusiast Forums > Mitsubishi Models > Mitsubishi Diamante
Sign in using an external account
Register Forgot Password?
Search

Welcome to the Mitsubishi Forum - Mitsubishi Enthusiast Forums.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-03-2008, 09:29 PM
dsm1990gsx's Avatar
Super Moderator
 
Join Date: Oct 2007
Location: Pottstown, Pa
Posts: 4,694
Default Abs light on

Hey guys just wanted to know if anyone has had the same problem that I am running into now. My g/f's grandfathers 99 diamante has an abs light for the rf speed sensor. I ohmed the sensor and it was in spec. I also ohmed the wire from the abs moduleconnector to the rf speed sensor and that was good. It looks like he has a bad abs module but didnt want to replace it unless I was 100% sure. Anyone have any ideas??? Thanks.

This ad is not displayed to registered members.
Register your free account today and become a member on MitsubishiForum!
__________________
2004 Ford Escape Xlt
2001 Mercury Sable
1990 Tsi Awd 12.8 @110 s16g @ 22lbs 2.0 60 ft.
-13.3 @114 holset hx35 @ 20lbs *needs new driver mod
1992 galant vr4
Reply With Quote
  #2  
Old 02-12-2008, 06:15 PM
dsm1990gsx's Avatar
Super Moderator
 
Join Date: Oct 2007
Location: Pottstown, Pa
Posts: 4,694
Default RE: Abs light on

Anyone w/an idea?
__________________
2004 Ford Escape Xlt
2001 Mercury Sable
1990 Tsi Awd 12.8 @110 s16g @ 22lbs 2.0 60 ft.
-13.3 @114 holset hx35 @ 20lbs *needs new driver mod
1992 galant vr4
Reply With Quote
  #3  
Old 02-12-2008, 11:56 PM
Senior Member
 
Join Date: Feb 2008
Location: houma, louisianna
Posts: 346
Default RE: Abs light on

hello! in my 20 years at a mitsubishi dealership i have never replaced an abs module. they just dont go bad. my money is on the sensor. where did you get your ohm specs?? make sure it is correct. another thing i have seen is the abs ring that is on the hub is damaged or has debris on it. the sensor head is mounted on top of it. round ring with even teeth on it. be sure to check. if you have a scanner, go into the abs system and select data then bring up that particular sensor. when you drive it watch to see does it have the same speed as the vehicle itsself. if it doesnt thats why the light comes on. sensor or ring is bad!! good luck!! greg... ps: if you have a different size tire on the r/f than is on the rest of the car that also will make the light come on. its turning a different speed than the rest of the tires. the abs module has to see each sensorhaving the same speed or it will turn on the light!
Reply With Quote
  #4  
Old 02-13-2008, 07:58 PM
dsm1990gsx's Avatar
Super Moderator
 
Join Date: Oct 2007
Location: Pottstown, Pa
Posts: 4,694
Default RE: Abs light on

Jgbrules thanks for the help, I did check the sensor ring, its not cracked or anything like that. I got the ohm specs from alldata, I compared the rf w/ the lf and i got the same reading on my dvom. He has all the same size tires on it too so I know thats not the problem. And my scanner I cannot access and pids to monitor the vehicle speeds or I probably would have figured it out by now lol. So maybe he should take it to a mitsu dealer to get it diag.
__________________
2004 Ford Escape Xlt
2001 Mercury Sable
1990 Tsi Awd 12.8 @110 s16g @ 22lbs 2.0 60 ft.
-13.3 @114 holset hx35 @ 20lbs *needs new driver mod
1992 galant vr4
Reply With Quote
  #5  
Old 02-14-2008, 09:54 PM
Senior Member
 
Join Date: Feb 2008
Location: houma, louisianna
Posts: 346
Default RE: Abs light on

good choice!! let me know what they find!!
Reply With Quote
  #6  
Old 01-03-2009, 07:22 PM
 
Join Date: Jan 2009
Posts: 2
Default RE: Abs light on

What was thesolution to your problem? I have a 2001 Diamante and my ABS light comes on when I hit 90 KM/hr (55mph) it resets when I turn off the car, the ABS works fine as long as the light is off. I think it could be dirt or build up on a sensor that cause the sensor to not get a good signal at higher speeds.
Reply With Quote
Old 01-03-2009, 07:22 PM
 
 
 
Reply

Tags
2001, 2007, 3000gt, abs, airtrek, antilock, brake, diamante, eclipse, galant, light, location, mitsubishi, outlander, scanner, sensor


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 04:39 PM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.