1st Generation This includes all Eclipses, Talons, and Lasers built from 1990-1994.

92 GSX Turbo Timming issue

  #1  
Old 09-20-2009, 02:13 PM
Junior Member
Thread Starter
Join Date: Sep 2009
Posts: 1
Default 92 GSX Turbo Timming issue

I have a 1992 Eclipse GSX AWD 2.o Liter Turbo, completely rebuild, egine starts and idles smooth. Lacks Power, checked timing and componants, The Timming will not advance seems to be at least 15 deg retard. Checked and rechecked timimg belt and componants alignment as well as the Crank/Cam Sensor, Wires Ect. Sent the ECU out to be checked.

Out of Ideas, can anyone shed some light on what's going on with this car? This is my first run in with a tuner, only experience has been with American Muscle.

Thanks in advance
 
  #2  
Old 09-20-2009, 03:41 PM
dsm1990gsx's Avatar
Super Moderator
Join Date: Oct 2007
Location: Pottstown, Pa
Posts: 4,681
Default

Did you set the base time w/ a timing light?
 
  #3  
Old 09-21-2009, 07:07 AM
Super Moderator
Join Date: Jan 2006
Location:
Posts: 11,758
Default

When you say lacks power are you saying it seems like its misfiring, or is it just not boosting?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
abrammich
New Members Area
1
05-19-2013 07:33 AM
CanadianOutlander
Mitsubishi Outlander
5
10-03-2007 06:43 AM
Kaede.Noir
2nd Generation
10
09-20-2007 01:15 AM
xp8ntballkid309x
2nd Generation
0
07-26-2007 12:58 AM
xp8ntballkid309x
2nd Generation
14
07-13-2007 04:15 PM


Thread Tools
Search this Thread
Quick Reply: 92 GSX Turbo Timming issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.