Help Identifying what Relay controls in Eclipse Spyder 2002 - Mitsubishi Forum - Mitsubishi Enthusiast Forums


Eclipse Frequently Asked Question Section This section is only for FAQs, not Q&A. If you have an FAQ reply to submit, contact a moderator or admin.
Sponsored By:
Sponsored By:

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 01-01-2016, 10:29 PM
Junior Member
Thread Starter
 
Join Date: Jan 2016
Posts: 3
Default Help Identifying what Relay controls in Eclipse Spyder 2002

2002 Spyder 2.4L. convertible

Having some electrical challenges recently. Battery goes dead due to something running after I turn off ignition.
  • I believe i have some water leakage issues around door mirror that may or may not be part of problem.
  • I was having issues with radio working on and off where i would loose FM but AM would still typically work and dome light would sometimes come on when i made a sharp turn. I hadn't narrowed that issue down and started to have this new issue.
  • When i turn off engine if i have the heater fan on it will continue to run after i turn off ignition.
  • Disconnected Negative Battery cable and with meter checked amps on negative terminal and i'm getting 3.40 range.
    • I started pulling fuses and relays and found one relay that when I pulled it out the amps dropped to 0.10 so i think i at least have my culprit narrowed to a starting point but I don't know what it is controlling.
      • The relay is in a small narrow compartment under hood next to the main fuse/relay box. It's 'A' in the straight line of relays next to the Security/Theft System relay. It has the engine symbol on it but that's it. So the ask is does anyone by chance know what that first slot controls? Or does the overlying issue sound familiar to anyone to help speed up the trial and error process?
      • Relay checks out with continuity check as Normally Open type relay.
The car will start without the relay in but not sure yet what I'm living without with the relay removed. I may have more input tomorrow as i continue to trial and error but it's cold and dark out and I stopped at this point and looking for some feedback if by chance anyone has any.

Last edited by nmiller67; 01-01-2016 at 10:36 PM.
Reply With Quote
  #2  
Old 01-02-2016, 12:16 AM
Senior Member
 
Join Date: Nov 2013
Location: Winnipeg, mb
Posts: 565
Default

It sounds like you are on the right track.
I don't have a wiring diagram but check high current things outside the car... Lights, horn, A/C, rear defrost, pwer/heated mirrors, power roof if equipped, etc.

It probably only controls one thing...

The relay could be fine, the block itself may have some corrosion or something on it that could be causing current jumps...

From the sounds of it you probably have leakage somewhere else to cause the stuff above that's likely a different problem but not related to the drain.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help identifying body kit for 98 Eclipse NeverEnough 2nd Generation 5 10-22-2010 07:25 PM
Need help identifying a head. PurpleOctopus Everything else 4 03-01-2009 02:10 PM
Help Identifying resovoir gringo69 2nd Generation 2 01-27-2009 01:32 AM
help identifying a comedian BLAZE GS Off Topic 5 05-01-2008 04:20 PM
help.. identifying a gs turbo from a gs n/a insanechulo27 2nd Generation 5 09-26-2004 07:16 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 08:43 PM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.