Everything else Good at troubleshooting? Have a non specific issue that doesnt fit into the other categories?? Ask it here!

2008 outlander lit up like a christmas tree after boost

  #1  
Old 05-14-2016, 09:46 PM
Junior Member
Thread Starter
Join Date: May 2016
Posts: 6
Default 2008 outlander lit up like a christmas tree after boost

sad to say something happened when i got a boost last weekend... no idea what happened but after i had a full system meltdown on my dash, lost my speedo, odometer not working either, and it cycles through the warnings of

check abs
check traction control
check engine
tire pressure warning
the 4x4 is flashing "4wd" then "lock" alternating one for the other


only thing on the dash working properly is the tach...

checked all the fuses but none seem blown... not sure whats going on
 
  #2  
Old 05-14-2016, 10:07 PM
Junior Member
Thread Starter
Join Date: May 2016
Posts: 6
Default

got a u0100 code(lost communication with ecm/pcm "a")
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
JRK5892
Mitsubishi Outlander
5
07-01-2013 12:54 PM
jsrd
Mitsubishi Outlander
11
12-26-2008 12:28 PM
burnmyeyes
Sights N Sounds
2
10-13-2006 04:30 PM
Maximus99
Off Topic
2
08-20-2006 11:01 PM
jcasaccio
Mitsubishi Montero & Montero Sport
3
03-23-2006 12:33 PM


Thread Tools
Search this Thread
Quick Reply: 2008 outlander lit up like a christmas tree after boost


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.