Everything else Good at troubleshooting? Have a non specific issue that doesnt fit into the other categories?? Ask it here!

Back up camera not working.

  #1  
Old 05-30-2017, 04:48 PM
Junior Member
Thread Starter
Join Date: May 2017
Posts: 2
Default Back up camera not working.

Hello everyone!

I have a 2014 Mitsubishi Outlander GT that was purchased brand new 3 years ago. My back up camera suddenly stopped working and I took it in and they said it was no longer under warranty, and I needed to replace the entire radio and everything since it was integrated. My issue is that the radio, bluetooth and everything still work fine, so I'm confused as to why the back up camera would just decide to stop working. They said it would cost $825 to replace it, but it's only 3 years old and I don't think it should have crapped out this soon. I'm super confused. Any advice or trouble shooting that maybe it could be? Thanks
 
  #2  
Old 06-03-2017, 11:01 PM
catacami's Avatar
Senior Member
Join Date: Apr 2007
Location: Milton, Ontario, Canada
Posts: 124
Default

Originally Posted by ajkhodge View Post
Hello everyone!

I have a 2014 Mitsubishi Outlander GT that was purchased brand new 3 years ago. My back up camera suddenly stopped working and I took it in and they said it was no longer under warranty...
Thanks. Good to know about this
 
  #3  
Old 03-26-2018, 04:32 PM
Junior Member
Join Date: Mar 2018
Posts: 1
Default Never getting a Mitsubishi again. Poor customer service

I have the same issue with my back up camera and they also told me that I would need to replace my entire radio "head" to fix the issue. Mine is also a 2014 and no longer under warranty for that. Rhey wanted $1700 to change out the radio and also charged me $200 to look at it and tell me they couldn't fix it.

I also want to point out that a week after getting my Outlander the radio went completely quiet and no volume came out. I tried changing the station, making a call, etc, and nothing. Then when I got to my destination and restarted my car it started working. I notified the dealership about this because I thought there was an issue. They pretty much said "nope, it must have been the radio station.
". They treated me like a dumb girl..... I have also complained about the back up camera going completely dark at times before it went out. Again, it only happened a hard full of times but since we couldn't get it to do it at the dealership, we were making it up.

oh, and we ordered our car in black and actually bought it before it arrived. When we got it home the next day we realized that the taillight was cracked. We let them know and they brushed it off. Never offered to fix it and acted like we must have crashed into something.

We have also had the Outlander not start 3 times now. We had it towed and it started when it got to the dealership. Every time this happened they would say "we don't know what you were doing wrong, it started for us" we talked to a mechanic the last time and he said it is experiencing "Vapor Lock"....... Why is my new car having vapor lock issues? We do all if the oil changes, maintenance, etc.

One more thing! I almost forgot. I had to have the brakes changed recently. They said that the rotor was warped and causing damage. They also said they are seeing this a lot with newer Mitsubishi's..... ugh


I have always liked Mitsubishi, but unfortunately this has been very disappointing for us and we probably won't buy from them again.
 
  #4  
Old 03-28-2018, 04:21 PM
Junior Member
Join Date: Mar 2018
Posts: 1
Default

Did anybody resolve this issue of reversing camera without replacing the head unit ?
 
  #5  
Old 07-03-2018, 09:44 AM
Junior Member
Join Date: Mar 2012
Posts: 1
Default

Just started experiencing the problem. I haven't really looked into it but was rather upset when I called the dealership and the first thing he said was "replace the radio" and then dropped the "NOT everything is covered in the bumper to bumper. The car is but not the radio."
Sounds to me as if this is known to them and they have an automatic response. mentioned going with an Aftermarket radio, which adds more proof to my theory this is a known issue with the OEM radio camera.
 
  #6  
Old 10-28-2018, 07:57 PM
Junior Member
Join Date: Oct 2018
Posts: 1
Default Same problem !


Hi there,
We are in the exact same boat with car year and issue. Did you ever figure out a way to get it done cheaper or did you go with dealer recommendation ?


Originally Posted by ajkhodge View Post
Hello everyone!

I have a 2014 Mitsubishi Outlander GT that was purchased brand new 3 years ago. My back up camera suddenly stopped working and I took it in and they said it was no longer under warranty, and I needed to replace the entire radio and everything since it was integrated. My issue is that the radio, bluetooth and everything still work fine, so I'm confused as to why the back up camera would just decide to stop working. They said it would cost $825 to replace it, but it's only 3 years old and I don't think it should have crapped out this soon. I'm super confused. Any advice or trouble shooting that maybe it could be? Thanks
 
  #7  
Old 06-10-2019, 12:09 PM
Junior Member
Join Date: Jun 2019
Posts: 1
Default

I have the same problem on a 2013 Outlander. Works intermittently. Gives me a blue screen before shutting down.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
lokks
Mitsubishi Outlander
2
04-11-2014 05:39 PM
monstero03
Audio/Visual Electronics
2
02-16-2014 01:40 AM
Sapper0145
Mitsubishi Montero & Montero Sport
0
01-16-2013 08:36 AM
tbanucci
Mitsubishi Outlander
30
03-29-2007 10:50 AM
jdmeclipse92
2nd Generation
0
10-29-2004 12:58 AM


Thread Tools
Search this Thread
Quick Reply: Back up camera not working.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.