Everything else Good at troubleshooting? Have a non specific issue that doesnt fit into the other categories?? Ask it here!

Installed New A/C Compressor-will not cycle on unless I jumper it

  #1  
Old 03-18-2017, 02:32 PM
Junior Member
Thread Starter
Join Date: Mar 2017
Location: Yuma, Arizona
Posts: 3
Default Installed New A/C Compressor-will not cycle on unless I jumper it

2000 Galant 2.4l I just installed a new a/c compressor and after charging the system the clutch wont engage unless I manually jumper it to the battery. Then everything works fine. I have checked for proper voltage and ground at the electrical connector 12.8 v with the selector switch on and fan set to high. This tells me the fuses and relays are working properly yet the compressor wont cycle on by itself. Any ideas? what have I missed?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Monteroman1994sr
Mitsubishi Montero & Montero Sport
2
01-04-2016 03:13 AM
tacole27
Mitsubishi Galant
0
10-05-2011 05:55 PM
krisFATAL
Mitsubishi 3000GT
6
09-23-2011 10:42 AM
mykets95
Mitsubishi Outlander
2
05-09-2011 11:38 AM
Dr. Zoidberg
Mitsubishi Outlander
0
03-18-2009 07:24 PM


Thread Tools
Search this Thread
Quick Reply: Installed New A/C Compressor-will not cycle on unless I jumper it


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.