04 endeavor low idle - Mitsubishi Forum - Mitsubishi Enthusiast Forums


Mitsubishi Endeavor This mid-sized sport utility vehicle offers a sporty look and excellent power, as well as a comfortable interior.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-11-2011, 09:35 PM
Junior Member
Thread Starter
 
Join Date: Jul 2011
Location: Springfield MA
Posts: 1
Default 04 endeavor low idle

After replacing the battery on my wife's 04 Endeavor, it started idling very low (200-500 rpm). my mechanic told me the regulator was bad. I replaced the alternator, but it still happens. It idles very low, sometimes causing a stall. when idling so low, battery is reading 12.7 volts (more or less), but if someone keeps rpms at 1000+, it shows 14.3 (more or less). What is causing this idle drop? Check engine light is not on.
Reply With Quote
  #2  
Old 09-15-2013, 12:53 PM
Junior Member
 
Join Date: Sep 2013
Posts: 1
Default

I had almost the same situation, after replacing the battery the Endeavor would not remain at idle the engine would shutoff. I found out the idle had to reset itself, so by driving and using the gas pedal the idle did not reset itself. I had to disconnect the battery (change the oil while disconnected) then I reconnected the battery and let the Endeavor idle for 10 minutes to relearn the idle speed. Now the Endeavor runs fine and does not shutoff.
Reply With Quote
  #3  
Old 09-21-2018, 11:42 AM
Junior Member
 
Join Date: Sep 2018
Posts: 1
Default Low idle/stalling

Thank you for sharing ... I'm having the exact same issue. I was told just to drive it and it would reset itself. It's been several days now and no change. I'll try out the method that resolved your issue. Thanks again!
Reply With Quote
  #4  
Old 10-07-2018, 07:00 PM
Junior Member
 
Join Date: Mar 2018
Posts: 3
Default

Quote:
Originally Posted by Shanen Rose View Post
Thank you for sharing ... I'm having the exact same issue. I was told just to drive it and it would reset itself. It's been several days now and no change. I'll try out the method that resolved your issue. Thanks again!

disconnect both terminals and zip tie them together. wash the suv, vacuum it, armor-all the tires(in other words, let it sit 15 mins, lol) then reconnect the terminals, start the car and let it sit and idle for 10-15 mins, then drive it for 5.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
idle low... agallardo 2nd Generation 19 04-21-2006 12:23 AM
low idle? please help nightseer Mitsubishi 3000GT 4 01-25-2006 01:14 AM
Low idle or missfire? drith 2nd Generation 3 01-03-2006 12:48 AM
Low Idle, Car Stalling with AC on cocosun 3rd Generation 4 08-09-2005 01:52 AM
01 Galant Stalling, low idle autorok Everything else 3 07-01-2005 02:33 PM


Tags
04, bad, battery, endeavor, engine, idle, idling, issue, low, mistubishi, mitsubishi, normal, set, stalling, weak

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 10:08 PM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.