Mitsubishi Galant A sporty mid-sized sedan offering the perspective buyer a change from the normal mid-size sedan class.

MisFiring Galant 2.0 GTI 4X4 1990

  #1  
Old 10-09-2006, 06:34 AM
Thread Starter
Join Date: Jul 2006
Posts: 3
Default MisFiring Galant 2.0 GTI 4X4 1990

Hi all, i posted this problem before, basically when my car has been running for around 100 miles or so i start to smell petrol, it starts to mis fire, buck, cut out and grey smoke comes out the back! this happened almost imediately in the summer when the car had been left in the sun all day.
I have replaced the fuel filter, used injector cleaner, replaced the ignition amplifier, replaced the coil packs, replaced the ecu, rewired the fuel pump. i get no check engine warning light and if you let the car cool off a little you can get a few more miles out of it before it happens again. Obviously something failing under high temp, any ideas anyone please.
Cheers
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Songster
Mitsubishi Galant
2
07-21-2013 02:20 PM
dewayne
Mitsubishi Montero & Montero Sport
11
06-23-2010 09:29 PM
socram
Mitsubishi Montero & Montero Sport
2
08-19-2009 07:12 AM
nick4x44ws
New Members Area
2
07-15-2006 02:52 AM
iriaf2001
For Sale / Trade
0
01-03-2006 10:39 PM


Thread Tools
Search this Thread
Quick Reply: MisFiring Galant 2.0 GTI 4X4 1990


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.