Mitsubishi Galant A sporty mid-sized sedan offering the perspective buyer a change from the normal mid-size sedan class.

Need professional advice. Turns over but wont start.

  #1  
Old 01-09-2014, 09:58 PM
Junior Member
Thread Starter
Join Date: Jan 2014
Posts: 2
Default Need professional advice. Turns over but wont start.

Hello guys! No lie. I didn't went to the new members are because I'm not looking to stay!


I'm willing to pay some ca$h if requested if I get my issue solved.

I really need some help with this crazy issue. If anyone willing to help that will be awesome. Thank you!


So...
2003 Mitsubishi Galant 2.4L Automatic transmission.


Turns over strongly with a lot of compression but wont start.


CEL throws 2 codes. Crank and cams sensors.


The engine has new coils, new timing belt which is 100% in correct time.


New sensors crank and cam sensors.


Fuel pump works. Starting fluid will keep the engine running but shutoff once starting fluid is released. Yes it does sparks and it hurts a lot if I get shock while testing.


200% sure ground isn't the problem.


My dad wants to turn the car on but I believe first I need to get rid of those two CEL codes but how?


I haven't (NOT) tried a new ECU because this ECU was working with the older motor as this new motor is a swap to replace the old blown motor.


Maybe a relay is causing the engine not to turn on?


Why the CEL still throws the 2 sensors code when the sensors are brand new?


Any thoughts? Thank you very much!

Any help is very appreciated! At least a message saying "IDK" it will be appreciated! Thanks!
 
  #2  
Old 01-10-2014, 09:49 AM
mxmikie's Avatar
Senior Member
Join Date: Sep 2005
Location: Bouse,az
Posts: 1,059
Default

Starting fluid will keep the engine running but shutoff once starting fluid is released... fuel problem,..........CEL throws 2 codes. Crank and cams sensors. ......bent pick up wheel from changing timing belt
 
  #3  
Old 01-12-2014, 01:51 PM
Junior Member
Thread Starter
Join Date: Jan 2014
Posts: 2
Exclamation

Originally Posted by mxmikie View Post
Starting fluid will keep the engine running but shutoff once starting fluid is released... fuel problem,..........CEL throws 2 codes. Crank and cams sensors. ......bent pick up wheel from changing timing belt
Thank you very much for your reply! Appreciated!

My dad called to the dealer and they told him the problem could be that vehicle came with 3 different ECUs models.


So probably the problem was after doing the motor swap this "new" motor runs with one of those 3 ECUs but obviously wasn't the same one as the old motor.


He called the junk yard to get the ECU from the car that motor was pulled out and they told him the car got crushed so he got a random ECU from other same model vehicle and it worked.


So the problem was the ECU but the ECU wasn't bad. The problem was a wrong model ECU.


Yes I'm talking about a 2003 Mitsubishi Galant 2.4L with automatic transmission. This vehicle model comes with 3 ECUs model and can't be interchangeable.

If this is true or not it's to blame the original Mitsubishi dealer technician who told us that.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
pauhana3
2nd Generation
1
02-05-2014 10:46 PM
ashulee12
PCM & Fuel Systems
3
10-21-2008 04:22 AM
jsneed24
Mitsubishi 3000GT
2
04-14-2008 09:39 PM
davedesmo
3rd Generation
13
09-28-2007 06:10 PM
travisc020
1st Generation
1
06-14-2006 09:06 PM


Thread Tools
Search this Thread
Quick Reply: Need professional advice. Turns over but wont start.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.