Mitsubishi Galant A sporty mid-sized sedan offering the perspective buyer a change from the normal mid-size sedan class.

Rough Idle ....P0400

  #1  
Old 10-29-2013, 02:14 PM
Junior Member
Thread Starter
Join Date: Oct 2013
Posts: 6
Default Rough Idle ....P0400

I have tried researching but still need more info if I may. I'm a 63 yo retiree but willing to do DYI and have time in my hands although back sometimes refuses to cooperate so please bear with me and hoping I get some reply to this post.

2000 Gallant 130k miles except for the current issue car is in excellent condition. Despite the rough idle it still averages 21-22 mpg and runs like a dream until I am on a stop light then it begins to shake. Temporary solution of course is put it in neutral.
It started doing this a little more than two weeks ago.

A two years ago a new EGR and solenoid was installed because "Check Engine Soon" light was on. It was all fine till recently when the light came on again but this time with a rough idle.

My neighborhood mechanic check it and said the solenoid was not grounded properly and fixed that problem and check vacuum hoses/connections and said they are all good but my valve cover gasket was leaking at the back side and needs to be replaced. Got that done but problem still persists, rough idle ( 70 % of the time) Sometimes it would just idle nicely. Mechanic said I have to change the intake manifold gasket since I have develop a gasket leak probably caused by being soaked in my oil leak. The diagnosis makes sense except for the following;

a) I thought a gasket leak is constant. I mean if that is the cause of the rough idle, it should be consistently rough, right?

b) I cleaned the intake manifold and everything around it and sprayed it with carburetor cleaner and the engine did not surge a bit, meaning no leak?? Right?

Since retirement funds are always low, I don't have the funds to support my mechanic's research on this issue and I am willing to do it myself.. Any help will be greatly appreciated!!

BTW, I'm in the Dallas area if you know a better mechanic.

Thanks for your replies!

ReySC
 
  #2  
Old 10-29-2013, 11:09 PM
mxmikie's Avatar
Senior Member
Join Date: Sep 2005
Location: Bouse,az
Posts: 1,059
Default

.P0400.....Exhaust Gas Recirculation Flow
 
  #3  
Old 10-30-2013, 11:16 AM
Junior Member
Thread Starter
Join Date: Oct 2013
Posts: 6
Default

Originally Posted by mxmikie View Post
.P0400.....Exhaust Gas Recirculation Flow
Thank you Sir! I realize that however I just my question is will a leaking intake manifold gasket trigger a P0400 code ? A million thanks for your time and response.
 
  #4  
Old 10-30-2013, 01:39 PM
Junior Member
Join Date: Nov 2012
Posts: 29
Default

OBD-II Trouble Code: P0400 Exhaust Gas Recirculation Flow Malfunction

Since the egr valve & solenoid are fairly new, it could be a bad line, faulty wiring or a defective valve or solenoid. Considering youre experiencing a rough idle, chances are either a bad line or one of the passages is severely blocked. If its a blocked passage, get some seafoam or a heavy duty carbon cleaner (gun section of walmart or cleaning section of sporting goods store). Hope this helps
 
  #5  
Old 10-31-2013, 02:28 PM
Junior Member
Thread Starter
Join Date: Oct 2013
Posts: 6
Default

Originally Posted by mikemitsu View Post
OBD-II Trouble Code: P0400 Exhaust Gas Recirculation Flow Malfunction

Since the egr valve & solenoid are fairly new, it could be a bad line, faulty wiring or a defective valve or solenoid. Considering youre experiencing a rough idle, chances are either a bad line or one of the passages is severely blocked. If its a blocked passage, get some seafoam or a heavy duty carbon cleaner (gun section of walmart or cleaning section of sporting goods store). Hope this helps
Thanks again. I just need to get in there and pull out the EGR valve inspect and clean and go from there.. Will keep you posted and I will try to ignore the intake gasket leak diagnosis of the mechanic. I think that is the one that threw me off..

Thanks for the reply and your time is well appreciated!

ReySC in Dallas.
 
  #6  
Old 11-04-2013, 01:39 PM
Junior Member
Thread Starter
Join Date: Oct 2013
Posts: 6
Default

mikemitsu,

Just an update, we pulled out the EGR and cleaned it thoroughly with Seafoam. Looks almost new and nice and shiny and you can see the inside. It was black inside when we pulled it out. Check the diaphragm and it is working just fine. It ran smooth and idled well for 20 miles then back to the same issue....Could this be a Solenoid issue ? I'm running out of suspects. Thanks a again Sir!
 
  #7  
Old 11-05-2013, 08:55 AM
Junior Member
Join Date: Nov 2012
Posts: 29
Default

What rpm is it at when it starts to get rough? & did the c.e.l come back on? What brand parts did u put in? A lot of the time aftermarket parts like that suck compared to o.e.m
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
PMR
Everything else
8
10-08-2015 08:29 PM
sierrenity
Mitsubishi Mirage
0
04-29-2009 10:09 AM
fritz
Mitsubishi Galant
3
10-02-2007 09:35 PM
Silvertooth
Intake, Headers and Exhaust
4
09-15-2007 01:10 PM
mdoc111
Mitsubishi Montero & Montero Sport
2
05-16-2007 05:06 PM


Thread Tools
Search this Thread
Quick Reply: Rough Idle ....P0400


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.