Mitsubishi Mirage This sport compact offers economy without compromising comfort.

Spark plug replacement and now have a miss at idle

  #1  
Old 01-06-2009, 04:35 PM
Junior Member
Thread Starter
Join Date: Dec 2008
Location:
Posts: 13
Default Spark plug replacement and now have a miss at idle

I just replaced my spark plugs, the old ones were really bad. Center electrodes all worn down.

Anyways, I replaced the spark plugs with autolite #69s (put dialectric grease in the boot of the spark plug wires), topped off the antifreeze, changed the engine oil with semi synthetic valvoline.

Now I have what I can best explain as a idle ad just off idle miss. misses up to about 1500rpm then is fine.

Did I do something wrong?

Help please and thanks in advance.

 
  #2  
Old 01-06-2009, 05:27 PM
Banned
Join Date: Feb 2006
Location: Austin, TX
Posts: 16,176
Default RE: Spark plug replacement and now have a miss at idle

Could be that stuff you put on the end of the wires causing the spark to arc off into the tube.

It could also be that one of the plugs isn't gapped right.

Make sure you check all the wires for corrosion or damage. Any break in conductivity will cause a miss.

If none of the above work, then you just bought crappy plugs.


 
  #3  
Old 01-07-2009, 04:19 PM
Senior Member
Join Date: May 2003
Location: United States
Posts: 1,187
Default RE: Spark plug replacement and now have a miss at idle

first, never use autolight garbage.

you should be using ONLY NGK plugs. Factory original. None of the "snake oil" crap like "splitfire" plugs, etc.

then also replace the plug wires/boots.
 
  #4  
Old 01-07-2009, 05:35 PM
Junior Member
Thread Starter
Join Date: Dec 2008
Location:
Posts: 13
Default RE: Spark plug replacement and now have a miss at idle

ok, gonna pull the plugs and put in ngk's. Already replaced the plug wires, cap, and rotor last night after my last message.
 
  #5  
Old 01-09-2009, 07:47 AM
Junior Member
Thread Starter
Join Date: Dec 2008
Location:
Posts: 13
Default RE: Spark plug replacement and now have a miss at idle

BPR5ES-11 sound correct?

 
  #6  
Old 01-09-2009, 06:09 PM
Banned
Join Date: Feb 2006
Location: Austin, TX
Posts: 16,176
Default RE: Spark plug replacement and now have a miss at idle

What brand of parts did you use? Wires/Cap/Rotor etc...

And yes those spark plugs look to be right.
 
  #7  
Old 02-13-2009, 10:45 AM
Junior Member
Thread Starter
Join Date: Dec 2008
Location:
Posts: 13
Default RE: Spark plug replacement and now have a miss at idle

replaced the spark plugs with the factory NGK spark plugs. Cap, rotor, and wires were from Autozone. Lifetime grade. Found that the #1 spark plug wire wasn't making a good connection in the cap. Runs much better.
 
  #8  
Old 02-13-2009, 06:42 PM
Banned
Join Date: Feb 2006
Location: Austin, TX
Posts: 16,176
Default RE: Spark plug replacement and now have a miss at idle

Congrats!
 
  #9  
Old 04-02-2009, 09:17 PM
Junior Member
Thread Starter
Join Date: Dec 2008
Location:
Posts: 13
Default Missing again

Well, it is back. Sometimes when I start my car up, sometimes it will stall. The check engine light comes on, but, because of the year, it doesn't store a code. I've heard something in some posts about possibly being a bad idle control motor. I know it is on the throttle body opposite the intake from the TPS. How do I know if this is the problem?
 
  #10  
Old 04-02-2009, 09:53 PM
Banned
Join Date: Feb 2006
Location: Austin, TX
Posts: 16,176
Default

Honestly that sounds like a spark issue to me.
 

Thread Tools
Search this Thread
Quick Reply: Spark plug replacement and now have a miss at idle


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.