Mitsubishi Montero & Montero Sport This sport utility vehicle offers more size than the other Mitsubishi SUVs, but manages to keep a sporty look and comfortable feel, unlike many larger SUVs.

Gen 1 2.6 wont start. NEED HELP!!!

  #1  
Old 02-11-2010, 08:22 PM
Junior Member
Thread Starter
Join Date: Feb 2009
Posts: 12
Default Gen 1 2.6 wont start. NEED HELP!!!

Ok here is the whole story. I was driving back to my apartment and my battery light came on so i thought that was kinda weird. Then my engine temp started to rise so i pulled over and there was steam coming from my engine bay. I thought that it would be a radiator hose or heater hose. I then realized that it was my water pump had basically exploded. The bearings were shot and i had lost almost all of my fluid. I had it towed home.

I got a new water pump from advance auto and put it in tensioned up the pullys and tried to start it. It wouldnt start it would crank over fine but there was not fire.

Since then i have replaced the dizzy rotor and cap. New plugs and wires. I dont think i needed any of those. I have checked to make sure that i have spark at each cylinder and i do. Then i checked to make sure that i had fuel squirting in the carb and i do. I also did a compression test and it is pretty low. But its a cold engine and im in a parking lot for my apartment in northern Wisconsin. I have checked timing with a timing light and it seams to be right were it should be. I have tried ether and still havent been able to get even a puff or a chug out of the thing. I am completely stumped. Has anyone had this problem or know of how to fix what is wrong. The head is the only thing that i can think of but i have compression and I should at least have some sort of chug. even if there is a crack or loss of compression. Please Help
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Sk8eR_PR
Mitsubishi Galant
2
01-12-2014 01:51 PM
rafael_o0o0
Mitsubishi Eclipse & Eclipse Spyder
0
09-23-2011 04:10 PM
DriftnROCKER77
Suspension
0
01-16-2008 01:20 AM
raff1ut
PCM & Fuel Systems
3
03-20-2007 11:18 AM
raff1ut
Everything else
4
02-21-2007 02:54 PM


Thread Tools
Search this Thread
Quick Reply: Gen 1 2.6 wont start. NEED HELP!!!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.