Mitsubishi Montero & Montero Sport This sport utility vehicle offers more size than the other Mitsubishi SUVs, but manages to keep a sporty look and comfortable feel, unlike many larger SUVs.

Instrument Panel Electrical Issue???

  #1  
Old 03-15-2019, 12:52 AM
Junior Member
Thread Starter
Join Date: Mar 2019
Posts: 5
Default Instrument Panel Electrical Issue???

Hoping to get some expert input on an issue I can not figure out.

Some Back info;
Jan 2019, I purchased a 2000 Montero Sport XLS 4x4 with 160k miles on it. One thing I noticed when I placed the vehicle in Drive, the "D" on the instrument panel would not light up. All others work. Mid February, I had a viper alarm installed by the authorized dealer where I purchased the alarm. When I drove away, I noticed to my surprise the light on "D" was now working!!!!

Now to my issue, This past weekend, March 9-10, I replaced Spark Plugs & wire set, valve cover gaskets/tube seals and air intake plenum gasket. All was fine after all that work, drove a full tank (approx 280 miles) with no issues. Today, 3/14 I noticed the "D" light is no longer coming on.

Any ideas?
 
  #2  
Old 03-16-2019, 03:50 PM
Senior Member
Join Date: Oct 2004
Location: Washington State
Posts: 1,311
Default

There are tiny bulbs that illuminate the drive letters in the instrument cluster. The bulb might be going out, or the contacts to the board getting bad. You can pull the instrument cluster and replace the bulbs. You might need to get them from the dealer, not sure if they are available online.
 
  #3  
Old 03-17-2019, 01:43 PM
Junior Member
Thread Starter
Join Date: Mar 2019
Posts: 5
Default

Thank you for the input. I’ll make that my project for next weekend. Hopefully that is all it is. Just seemed odd that it began to light up again after the alarm install and just went out. I will update in couple weeks. Thanks again
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
SEAbound
Mitsubishi 3000GT
1
01-08-2008 11:30 AM
cess_king
Everything else
3
12-08-2004 02:39 PM
cess_king
General Mitsubishi Chat
0
12-07-2004 01:02 AM
champu26
Mitsubishi Galant
0
02-25-2004 12:08 AM
Legion
2nd Generation
0
05-04-2003 08:19 PM


Thread Tools
Search this Thread
Quick Reply: Instrument Panel Electrical Issue???


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.