Slow acceleration and oil gage is at two then rises when I pick up speed. Any help with this. - Mitsubishi Forum - Mitsubishi Enthusiast Forums

Go Back  Mitsubishi Forum - Mitsubishi Enthusiast Forums > Mitsubishi Models > Mitsubishi Montero & Montero Sport
Reload this Page >

Slow acceleration and oil gage is at two then rises when I pick up speed. Any help with this.

Mitsubishi Montero & Montero Sport This sport utility vehicle offers more size than the other Mitsubishi SUVs, but manages to keep a sporty look and comfortable feel, unlike many larger SUVs.

Slow acceleration and oil gage is at two then rises when I pick up speed. Any help with this.

Reply

 
 
 
  #1  
Old 10-06-2007, 08:46 PM
Thread Starter
Join Date: Aug 2007
Posts: 15
Default Slow acceleration and oil gage is at two then rises when I pick up speed. Any help with this.

First, Thanks everyone for help on my last problem. New situation now. Once my truck is warmed up it is slow on pick when I am stopped at red light, stop sign etc.... I also notice the oil gage is at 2, and when I start to pick up speed it rises to normal operating level. once I am moving the truck runs great. I also notice that my acceleration cable is loose and plus when I revv up the engine to 1500 RPMs or so the oil gage rises some. It idles at 850-900 right now. Any advice guys 1995 Montero LS 3.0 automatic, 4wd 126k.

Ray
 
Reply With Quote
  #2  
Old 10-07-2007, 11:13 AM
Senior Member
Join Date: Feb 2007
Location: when a man and women fall in love, the man........
Posts: 3,348
Default RE: Slow acceleration and oil gage is at two then rises when I pick up speed. Any help with this.

well slow acceleration is a no brainer.......what oil do u use? because that engine gunk DOES get in with high miles and late changes......and the faster u accellerate......the pump moves faster and pumps oil faster.....at least thats my theory......u may want to ask around
 
Reply With Quote
  #3  
Old 10-07-2007, 12:34 PM
Thread Starter
Join Date: Aug 2007
Posts: 15
Default RE: Slow acceleration and oil gage is at two then rises when I pick up speed. Any help with this.

I just got the truck a few months ago and i've been working on it. I just started driving it four days ago.I changed the oil and oil filter three days ago using mobile 5000 w5-30. I noticed today when I was on the highway doing 65mph the oil pressure gage moves up to 6.
 
Reply With Quote
  #4  
Old 10-07-2007, 04:02 PM
Senior Member
Join Date: Feb 2007
Location: when a man and women fall in love, the man........
Posts: 3,348
Default RE: Slow acceleration and oil gage is at two then rises when I pick up speed. Any help with this.

thats probably because the pump has to work harder to keep up with the engine,rising pressure so everything stays well lubricated
 
Reply With Quote
  #5  
Old 10-07-2007, 04:19 PM
Thread Starter
Join Date: Aug 2007
Posts: 15
Default RE: Slow acceleration and oil gage is at two then rises when I pick up speed. Any help with this.

Is there anything I can do to fix this problem. Or does adjust on it's on...
 
Reply With Quote
  #6  
Old 10-07-2007, 07:48 PM
Senior Member
Join Date: Jan 2005
Posts: 362
Default RE: Slow acceleration and oil gage is at two then rises when I pick up speed. Any help with this.

Your oil pressure is normal.

Did you get an owners manual? Although mine is a 3.5L 1999, my manual says: (when warm)

1 to 2 is normal at idle
3 to 6 is normal at 3000rpm.

Mine has been running with these numbers for the last 150K miles.

Not sure about the acceleration problem since I'm not familiar with 95's. On mine, there is a switch on the center console near the ashtray marked "HOLD". (This is for use when driving on hilly roads when you want the transmission to stay in one gear) On mine, if this switch is accidentally switched on when starting out, the truck definitely feels bogged down.

Hope this helps,

Ron

 
Reply With Quote
  #7  
Old 10-07-2007, 10:00 PM
Thread Starter
Join Date: Aug 2007
Posts: 15
Default RE: Slow acceleration and oil gage is at two then rises when I pick up speed. Any help with this.

No hold button..... My A/T button is by the ash tray....
 
Reply With Quote
  #8  
Old 10-08-2007, 06:34 PM
Senior Member
Join Date: Feb 2007
Location: when a man and women fall in love, the man........
Posts: 3,348
Default RE: Slow acceleration and oil gage is at two then rises when I pick up speed. Any help with this.

u have a sport? right?
 
Reply With Quote
  #9  
Old 10-08-2007, 08:52 PM
Thread Starter
Join Date: Aug 2007
Posts: 15
Default RE: Slow acceleration and oil gage is at two then rises when I pick up speed. Any help with this.

It's an LS
 
Reply With Quote
  #10  
Old 10-11-2007, 07:13 PM
Thread Starter
Join Date: Aug 2007
Posts: 15
Default RE: Slow acceleration and oil gage is at two then rises when I pick up speed. Any help with this.

I had my transmission flushed today and the Mitsubishi service garage told me my tranny is in fail safe mode. It stays in 3rd gear to prevent anymore damage to tranny. Does anyone know if this is a case where I would have to to rebuild or replace tranny? They told me $90 an hour to diagnose. No telling how many hours it could take.
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
razi
New Members Area
0
08-12-2013 03:57 PM
rdaneel
Mitsubishi Montero & Montero Sport
1
02-18-2011 09:01 AM
candleladymn
Everything else
3
06-26-2009 04:05 PM
GETNKD
New Members Area
1
05-02-2005 08:25 PM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory