1st Generation This includes all Eclipses, Talons, and Lasers built from 1990-1994.

'93 Eclipse clutch pedal problem(s)

  #1  
Old 05-08-2009, 08:46 AM
Junior Member
Thread Starter
Join Date: May 2007
Posts: 15
Angry '93 Eclipse clutch pedal problem(s)

Hi all,

I have a 93 Eclipse with a 1.8L and manual trans. I was driving two weeks ago and the clutch pedal locked up. I was not able to depress the clutch at all. I removed the clutch master cylinder and the piston was frozen in the master cylinder. So I bought a new clutch master cylinder and tried to install it this week. My problem is when I try to attach the rod from the clutch master cylinder to the clutch pedal. To get the rod from the clutch master cylinder to attach to the pedal I have to have the pedal all the way down to the floor. I double checked the part number of the master cylinder with my parts store and they say it is the correct part. Could I have broken the clutch pedal or got it out of adjustment when the clutch master cylinder froze? Is the clutch pedal and the corresponding end that attaches to the clutch master cylinder one piece or is it pressed on the end or something. I measured from the firewall to the end of the rod from the master cylinder and it is approx. 3 3/4". I also measure from the firewall to the hole on the clutch pedal and it is approx. 6". Is 6" the correct distance or should this be less than 6"? Any insight would be appreciated. I have a Haynes manual but it doesn't have that level of detail. Anyone have a pdf of a shop manual???

Thanks,
Mike
 
  #2  
Old 05-08-2009, 08:42 PM
Super Moderator
Join Date: Jan 2006
Location:
Posts: 11,758
Default

Try and adjust the clutch pedal rod with the nut on there
 
  #3  
Old 05-09-2009, 09:12 AM
dsm1990gsx's Avatar
Super Moderator
Join Date: Oct 2007
Location: Pottstown, Pa
Posts: 4,681
Default

Like TE said make sure its adjusted properly and make sure you bleed all the air out of the system.
 
  #4  
Old 05-09-2009, 11:48 AM
Junior Member
Thread Starter
Join Date: May 2007
Posts: 15
Default

Thanks for the replies!

The clutch rod appears to be at the back of the master cylinder and I have the pushrod adjusted all the way out to the end. Still the pedal is all the way down to the floor when connected. I think something broke or is out of alignment with the clutch pedal assy. Could you measure the distance from the firewall to the hole in the clutch pedal where the clevis pin attaches? I would greatly appreciate it!!!

-Mike
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
RedPill
Everything else
0
05-16-2011 06:44 AM
wicked2407
2nd Generation
7
10-25-2006 06:07 PM
blk beauty 3kgt
Mitsubishi 3000GT
5
03-29-2006 02:28 PM
koodalgo
Everything else
2
03-28-2006 12:07 AM
jfvalejandrino
Mitsubishi Galant
0
06-08-2004 06:07 PM


Thread Tools
Search this Thread
Quick Reply: '93 Eclipse clutch pedal problem(s)


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.