1st Generation This includes all Eclipses, Talons, and Lasers built from 1990-1994.

94 Eclipse GS died while driving-no restart

  #1  
Old 08-17-2010, 09:53 PM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 4
Question 94 Eclipse GS died while driving-no restart

Have a 1.8 5 speed manual, was driving car and turned on stereo (which has subs and amp) and car stopped running. Wouldn't restart. Appears to have fuel, cranks over ok. Have power to distributor but no spark. Checked all fuses. Any ideas?
 
  #2  
Old 08-18-2010, 09:08 AM
Super Moderator
Join Date: Jan 2006
Location:
Posts: 11,758
Default

battery connection maybe where you connected your power for the system
 
  #3  
Old 08-19-2010, 08:37 PM
dsm1990gsx's Avatar
Super Moderator
Join Date: Oct 2007
Location: Pottstown, Pa
Posts: 4,681
Default

Did you pull the distributor cap off and inspect the rotor?
 
  #4  
Old 08-20-2010, 04:20 PM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 4
Default

Battery connection is good, distributor cap and rotor are good too. Are there any fusible links on this car? I wonder if there was a short in the amp and it burned something out when it powered up. By the way, the stereo and amp have been disconnected and it made no difference.
 
  #5  
Old 09-12-2010, 09:02 PM
mxmikie's Avatar
Senior Member
Join Date: Sep 2005
Location: Bouse,az
Posts: 1,059
Default

timing belt
 
  #6  
Old 09-13-2010, 06:53 AM
Super Moderator
Join Date: Jan 2006
Location:
Posts: 11,758
Default

Originally Posted by mxmikie View Post
timing belt
is this a joke?
 
  #7  
Old 09-13-2010, 01:11 PM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 4
Default

The resistors in the distributor went bad. Replaced distributor, still no start, no spark and no fuel. Replaced ECM with used one, still nothing. This is my sons car and when we replaced the ECM he was cranking it over and I noticed the cam timing mark was in the same position as before (there is a hole drilled in the cover to see mark, and I asked my son if him and his buddy checked the timing belt weeks ago, he said yeah), I told him to crank it over again, the cam sproket did not turn, broken timing belt. Interesting fact: After he cranked it over he left the ignition "on" and when I moved the cam sproket by hand I heard the fuel pump start and electrical pulse.
He said when him and his buddy couldn't get it to start and was towing it that he put the car in 2nd gear and popped the clutch at about 45 mph to try to start it, I assume that is when the timing belt snapped.
Lesson learned: Don't trust 20 year olds when they say they verified things and start troubleshooting from the basics yourself. Car is running again for now, LOL
 
  #8  
Old 09-15-2010, 10:34 PM
mxmikie's Avatar
Senior Member
Join Date: Sep 2005
Location: Bouse,az
Posts: 1,059
Default

Originally Posted by TheEngineer View Post
is this a joke?
like a heart attack
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Tmans20
Mitsubishi Montero & Montero Sport
1
07-14-2014 10:05 PM
svetter84
3rd Generation
0
08-07-2012 08:06 PM
mikr
Everything else
1
07-17-2011 05:13 PM
pj4411
Mitsubishi Montero & Montero Sport
2
06-10-2010 04:48 PM
kenlrw39
2nd Generation
7
10-05-2007 12:49 PM


Thread Tools
Search this Thread
Quick Reply: 94 Eclipse GS died while driving-no restart


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.