Strange starting issue - Mitsubishi Forum - Mitsubishi Enthusiast Forums

1st Generation This includes all Eclipses, Talons, and Lasers built from 1990-1994.

Strange starting issue

  #1  
Old 11-27-2017, 12:01 PM
Junior Member
Thread Starter
Join Date: Nov 2017
Posts: 1
Default Strange starting issue

I have a 94 eclipse 1.8 5 speed new battery and starter. The issue I have is when I go to start it have to repeatedly turn key from start to run, start to run back and forth back and forth a while before it turns over, it has new battery and starter. I unplugged the clutch switch and same thing. Any ideas?
 
  #2  
Old 02-03-2019, 09:30 AM
mxmikie's Avatar
Senior Member
Join Date: Sep 2005
Location: Bouse,az
Posts: 1,056
Default

replace the ignition switch behind the key switch
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
justin210485
Mitsubishi Montero & Montero Sport
7
03-06-2015 11:11 AM
bstarski
Mitsubishi Montero & Montero Sport
5
04-01-2009 05:57 PM
tcp
Mitsubishi Outlander
22
03-05-2008 09:51 AM
Ziggy
2nd Generation
4
05-29-2007 02:24 PM
chasha82
Everything else
4
05-25-2006 03:00 PM


Thread Tools
Search this Thread
Quick Reply: Strange starting issue


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.