Everything else Good at troubleshooting? Have a non specific issue that doesnt fit into the other categories?? Ask it here!

2003 Montero brake issue

  #1  
Old 03-22-2018, 11:33 AM
Junior Member
Thread Starter
Join Date: Mar 2018
Posts: 1
Unhappy 2003 Montero brake issue

I have a 2003 Montero. A couple of weeks ago the brakes ABS started pulsing as if on a slippery surface every time the brakes are applied at slow speed. I also noticed that when I approached 65 mph or so the car would get very rough for awhile then smooth out. The traction control lights also started coming on after around 10 min. drive time. I took it to my normal every day mechanic. They put it on analyzer which showed code 26 but they could not figure out what that code meant. Took it to local Mitsubishi dealer. For days, the service manager would call me to tell me they were still trying to pinpoint the problem. Finally he called me with what he said was the worst case scenario. He said the "ABS booster; needed to be replaced and the part alone was $1900. I ended up getting a rebuilt booster which the Mitsubishi shop installed only for the vehicle to have the same exact symptoms. He claimed the rebuilt Brake booster I bought must also be bad. I disagreed to no avail. I called the man who sold me the rebuilt booster unit. He seems very knowledgeable about what he does. He asked me questions about what the vehicle was doing and then told me that it had nothing to do with the booster. He said the booster is what he called a 'dumb unit' that takes it's orders from a computer. Said the problem was computer. Not the booster. I have not had a further discussion with the Mitsubishi shop yet. Please advise. I need an expert because this is obviously out of my local Mitsubishi mechanics' league.
 
  #2  
Old 03-27-2018, 09:11 AM
Junior Member
Join Date: Oct 2014
Location: Sacramento
Posts: 23
Default brake issue

I had an issue which was a "skoink" noise after touching the brakes, but not immediately. Tap brakes, and a minute or so later a noise. I found on youtube someone with same issue. Turns out it was brake booster, a round thing under hood near firewall on drivers side. My shop told me it was computer, I told them NO, give me my car back. I went to Mitsi dealer, but booster for 160 dollars and removed old booster and installed new one. Problem gone.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
LetterT
Mitsubishi Montero & Montero Sport
0
12-02-2013 07:51 PM
FLYONWALL
Mitsubishi Montero & Montero Sport
3
04-28-2013 01:57 PM
dukeyjoe
Mitsubishi Outlander
4
11-07-2012 05:41 PM
bobneel
Everything else
1
01-13-2012 08:27 PM
scrimshank
Mitsubishi Montero & Montero Sport
0
04-14-2009 11:57 AM


Thread Tools
Search this Thread
Quick Reply: 2003 Montero brake issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.