Everything else Good at troubleshooting? Have a non specific issue that doesnt fit into the other categories?? Ask it here!

Cruise Control NOT WORKING?

  #1  
Old 02-25-2006, 08:41 PM
Thread Starter
Join Date: Jan 2006
Location:
Posts: 28
Default Cruise Control NOT WORKING?

I was kinda surprised to find out that my cruise control doesn't work at all. I've tried to make it work several times to no avail. I would really appreciate if anyone could help me. Thankx.
 
  #2  
Old 02-26-2006, 12:29 AM
Join Date: Feb 2006
Location:
Posts: 48
Default RE: Cruise Control NOT WORKING?

i have the same problem with my 91 eclipse, what year is yours?
 
  #3  
Old 02-26-2006, 11:20 AM
Banned
Join Date: Jan 2006
Location:
Posts: 752
Default RE: Cruise Control NOT WORKING?

Check the vacuum lines that run to the cruise control units, a lot of the time the lines become cracked and broken or just has fallen off.
 
  #4  
Old 02-26-2006, 06:10 PM
Thread Starter
Join Date: Jan 2006
Location:
Posts: 28
Default RE: Cruise Control NOT WORKING?

I have a 99 eclipse. Thanks I'll try lookin at the vaccum lines.
 
  #5  
Old 03-06-2006, 03:31 AM
Join Date: Apr 2005
Location:
Posts: 85
Default RE: Cruise Control NOT WORKING?

Another thing is simply check the fuse.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Soleinova
Mitsubishi Outlander
2
12-20-2018 12:46 PM
Pajoz
Mitsubishi Montero & Montero Sport
6
05-18-2017 12:31 PM
Bob3905
Mitsubishi Montero & Montero Sport
1
02-22-2015 06:42 PM
doodman
Mitsubishi Galant
0
02-04-2009 03:10 PM
btv401
Mitsubishi Outlander
0
06-05-2007 08:32 AM


Thread Tools
Search this Thread
Quick Reply: Cruise Control NOT WORKING?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.