02 Sensor Woes

  #1  
Old 08-21-2016, 04:27 PM
Junior Member
Thread Starter
Join Date: Jun 2012
Location: Ventura, CA
Posts: 3
Default 02 Sensor Woes

When handed the Fail certificate for my 2002 Montero Sport 3.5L from the smog station, I went straight to Pep Boys for the Bank 2 Sensor 2 02 sensor specified on the paperwork as being faulty. With the Bosch 13801 sensor in hand, I went home and got to work. The plug didn't line up exactly with the insert, so I broke of a little plastic lip on the Bosch, and slipped it in.
Alas, the check engine light keeps coming back on. Twice I've disconnected the battery for 20 minutes. Though the memory is wiped out, the radio continues to work, and doesn't need to be rebooted with a code.
Any insight would be helpful. Thanks!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Obakemono
Mitsubishi Montero & Montero Sport
3
07-28-2010 02:17 AM
GRN98
Mitsubishi Montero & Montero Sport
2
07-28-2009 06:50 AM
itsymitsispyder
Everything else
1
03-10-2009 12:51 AM
Big_Bird
Mitsubishi Outlander
21
06-11-2007 11:41 AM
HubbaHoward
Mitsubishi Outlander
22
03-08-2007 11:38 PM


Thread Tools
Search this Thread
Quick Reply: 02 Sensor Woes


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.