Compressor Help please

  #1  
Old 08-20-2017, 09:10 AM
Junior Member
Thread Starter
Join Date: Aug 2017
Posts: 1
Default Compressor Help please

Hey guys, I'm new to the forum and apologize if you've been through this topic. I have 2002 GT Eclipse. I read a few threads but it never hit this issue.

Anyway, AC used to work well while my car was moving but at idle it blew warm air but no AC button flash. My AC compressor starting sounding like a buckets of gravel a few months later so i replaced it with a refurbed one. Put the refurbed on (4.1 oz of PAG), vac'd the system and filled with proper amount of freon by professional machine.

Now my AC blows cold at idle but when car is in motion the AC button light flashes and cold air stops. If i turn car off the AC resets and blows cold at idle. Any ideas????
 

Last edited by Againster; 08-20-2017 at 09:11 AM. Reason: year and model missing
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
slimmer6
Everything else
0
08-11-2014 08:42 PM
cpark
3rd Generation
0
11-04-2009 10:33 PM
jgolli
2nd Generation
7
04-29-2007 12:14 PM
derf
2nd Generation
3
10-12-2005 06:44 PM
ChrisandJ
General Mitsubishi Chat
1
02-16-2004 11:03 AM


Thread Tools
Search this Thread
Quick Reply: Compressor Help please


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.