Intake, Headers and Exhaust Custom Exhaust? New Headers? Need Opinions on Intakes? Discuss making your ride breathe better here.
Sponsored by:
Sponsored by:

4G63 MAF goes nuts

  #1  
Old 09-24-2018, 02:15 PM
Junior Member
Thread Starter
Join Date: Sep 2018
Posts: 1
Default 4G63 MAF goes nuts

Hi
I own a 2003 Outlander 2.0 4WD with 4G63 motor, and the MAF is making weird readings but only at throttle position from 5,5-7%.
In this position the MAF is showing 400-500 g/s more then normal. When the throttle pass the 7% it goes back to normal. I bought used MAF and it have same (identical) symptoms.
Is also another MAF defective or I should search the problem else? Also the idle control is rev up with no reason and even if I turn the steering wheel on place the revs goes up.
MAF is same as on a picture.
Thank you for any tips.
ERR
 
Attached Thumbnails 4G63 MAF goes nuts-md336481_3.jpg  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Moshik Galimidi
1st Generation
0
08-15-2017 06:03 PM
sempron555
Mitsubishi Galant
3
06-09-2014 08:20 AM
kounterfeit402
2nd Generation
6
03-15-2007 01:20 PM
marcmindte
Mitsubishi Montero & Montero Sport
6
05-08-2006 10:17 PM
ictponder
3rd Generation
0
04-29-2006 02:05 AM


Thread Tools
Search this Thread
Quick Reply: 4G63 MAF goes nuts


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.