Indicator and hazards not working - Mitsubishi Forum - Mitsubishi Enthusiast Forums


Interior Wiring Discuss everything in the car here, from boost controllers to custom wiring.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-27-2018, 06:54 PM
Junior Member
Thread Starter
 
Join Date: Jul 2018
Posts: 2
Default Indicator and hazards not working

Good day guys, I have a 2011 outlander and the indicator or turn signals plus hazard lights have just stopped working. Have checked all the fuses in the engine bay and inside the passenger fuse box and they all good. Looking for the next steps to fix the issue. Many thanks

Last edited by Waynesworld; 07-27-2018 at 07:05 PM.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Turn Signals, Left Working, Right not, Hazards wiggerjw Interior Wiring 2 05-28-2015 10:38 PM
signal lights and hazards not working Raider Mitsubishi Diamante 1 02-24-2015 02:38 PM
4WD Indicator Light Not Working - Diff Not Engages??? kostovski.dragan Mitsubishi Montero & Montero Sport 0 07-30-2014 04:55 AM
'01 Galant Turn Signals/Hazards not working JennJenn Everything else 0 07-22-2012 03:44 PM
Turn Signals/Hazards not working Jenn Olsen Everything else 0 12-29-2011 01:35 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 09:53 PM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.