Mitsubishi Lancer and Lancer Sportback Newer to the United States, the Lancer line offers a sporty compact sedan, with all of the fine styling of the performance minded Evolution.

Please help... 2002 Lancer OZ

  #1  
Old 06-12-2013, 01:53 AM
Junior Member
Thread Starter
Join Date: Jun 2013
Posts: 1
Default Please help... 2002 Lancer OZ

Hi, I have a 2002 Mitsubishi Lancer OZ Rally edition and I'm having a problem with it. Here's the scenario, I removed the battery to charge it because when I started the car a few days ago it did a hard start but it did start at 1 go. When I installed the battery back, the car started real good. The problem was when I drive the car, it accelerates good but when I decelerate it loses RPM and the engine shuts off. My questions are,

1. Does the removing the battery caused this problem?
2. Should I replace a new battery? ( I don't know how old is the current battery installed and don't know if I need to replace it )
3. Any fix that I can do to this issue?

Please help.
 

Last edited by Mushu; 06-12-2013 at 02:23 AM.
  #2  
Old 06-17-2013, 11:41 AM
Former Sponsor
Join Date: Feb 2013
Posts: 63
Default

Have your battery tested, it isn't the cause of your car stalling but it is a good indicator of whether it needs to be replaced soon or not.

Chances are you may have a vacuum leak somewhere or your throttle position sensor may be on its way out or the IAC is sticking.

Try cleaning the throttle body and iac and see if it helps.
 
  #3  
Old 12-13-2014, 10:06 PM
Junior Member
Join Date: Dec 2014
Location: New Haven Ct
Posts: 2
Default !Question!

I have the same issue!!! if you have been able to fix it plzz send me a DM! i have pretty much exhausted my options! thanks!
 
  #4  
Old 12-13-2014, 11:50 PM
Senior Member
Join Date: Jun 2013
Location: Northland, NZL
Posts: 1,219
Default

Originally Posted by Vasquez88 View Post
I have the same issue!!! if you have been able to fix it plzz send me a DM! i have pretty much exhausted my options! thanks!
that's vague, what exactly have you done?
 
  #5  
Old 01-27-2015, 09:53 AM
Junior Member
Join Date: Jan 2015
Posts: 7
Default

I found this. It may be related: https://mitsubishiforum.com/forum/mi...z-rally-46253/


Edit: 2015/01/30: 1 week after posting this, my car strart to do the exact same thing. It seems every times i unplug the battery (about 1 hour) the car struggle on IDLE the next 2 days. Anyone has an idea what could cause this to 3 of us? And looks like we are not the only ones!
 

Last edited by MadCore; 01-30-2015 at 09:18 AM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Crazygn
Mitsubishi Montero & Montero Sport
2
04-03-2013 12:17 PM
davep
Everything else
0
09-22-2011 09:14 AM
stbrian
Mitsubishi Galant
2
11-12-2010 10:19 AM
mikiewolfsz
Mitsubishi Galant
2
10-03-2008 02:19 PM
ruslancer
For Sale / Trade
0
03-05-2005 02:59 PM


Thread Tools
Search this Thread
Quick Reply: Please help... 2002 Lancer OZ


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.