Mitsubishi Mirage This sport compact offers economy without compromising comfort.

95 Mirage won't run.....Need Help Please.....

  #1  
Old 02-01-2010, 07:14 PM
Junior Member
Thread Starter
Join Date: Feb 2010
Posts: 4
Default 95 Mirage won't run.....Need Help Please.....

Hi i have a 95 mirage i've had it for about 2 months, so im pretty new the mitsu's i don't really know much about them yet. Well any way here is the problem.


I was driving the other day and it ran fine then i when to leave and it would barely start and didn't even have the power to move itself out of the drive way. Running terrible so i had to drive it to town then when i got back home and went to start it the next day it wouldn't start. There is black around the end of the tailpipe like its been running rich, i changed the spark plugs and they were fouled out pretty bad. When i changed them it still wouldn't start.They were black with carbon and covered in gas. I really haven't had much of a chance to look at it real good yet.

Is there any known engine issues with these cars? Its a 1.5L Maybe a headgasket or a bad sensor? The check engine light does not come on. I also am wondering what kind of obd port these cars have. i have a scanner but i'm not sure if it will work for this car.


Thanks in advance for the help..
 
  #2  
Old 03-03-2010, 03:12 PM
Junior Member
Join Date: Jul 2009
Posts: 3
Default

you may have a clog on the catalylic, check that out...
 
  #3  
Old 03-03-2010, 08:48 PM
dsm1990gsx's Avatar
Super Moderator
Join Date: Oct 2007
Location: Pottstown, Pa
Posts: 4,681
Default

Does it run better as the car warms up?
 
  #4  
Old 03-04-2010, 08:08 AM
Junior Member
Thread Starter
Join Date: Feb 2010
Posts: 4
Default

Well it ended up being the end of the crankshaft was boogered up and someone lined the timing marks up and JB Welded it and put it back together and sold it to you know who... I took the timing cover off and realized it was 1 1/2 teeth off... yea weird right? So, when i took the belt off of it i could move the crank gear 2 teeth each way, yea def not good. So i found a engine at a salvage yard in Ohio with 65k on it, bout 170mi from my house(the closest one i could find) threw it in there timed it up and new she runs great, twice as much power as it had before. The bad thing is that the engine would still be good if it weren't for the end of the crank. So, if any one needs any parts off of it let me know.

Thanks for the input.


Dustin
 
  #5  
Old 03-20-2010, 01:46 AM
juriskardowski's Avatar
Junior Member
Join Date: Jan 2010
Posts: 23
Default

it must be a clog somewhere in the catalytic. anyway where are you located at. if you are just near gardena, i can help you with that.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Analyzer52
Mitsubishi Mirage
0
12-06-2013 04:58 PM
driftin2u
2nd Generation
7
10-22-2007 05:22 PM
Jimps
Everything else
0
08-21-2007 10:00 AM
brian.tyalor
Mitsubishi Mirage
2
03-18-2007 04:10 AM
Shadowplane676
Mitsubishi 3000GT
8
12-23-2005 08:37 PM


Thread Tools
Search this Thread
Quick Reply: 95 Mirage won't run.....Need Help Please.....


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.