1st Generation This includes all Eclipses, Talons, and Lasers built from 1990-1994.

Did I let the belt slip ?

  #1  
Old 11-15-2009, 09:33 AM
Junior Member
Thread Starter
Join Date: Nov 2009
Posts: 10
Default Did I let the belt slip ?

Hey guys I sure hope someone can help me out here, I will try 2 keep it short. I replaced the headgasket on my 93 eclipse 1.8 , I tied the belt to the sprocket befor removeing it from cam and tried not 2 let it drop down any. I did turn the crank a very little bit mabe a half inch and when I get it all back togather it wont start only hit . and also it wants 2 keep cranking over after i let off the key,with key all the way off then it will finley stop? this is the first time this has happend. I got # 1 up 2 TDC with both vales closed on that clinder stuck dist. in with roter pointing down made that #1 wire , wired clockwise 1342 . no run. need help pLEASE.
 
  #2  
Old 11-15-2009, 10:11 AM
dsm1990gsx's Avatar
Super Moderator
Join Date: Oct 2007
Location: Pottstown, Pa
Posts: 4,681
Default

Sounds like the timing belt isn't timed right? Also check the basics fuel, compression and spark.
 
  #3  
Old 11-15-2009, 11:55 AM
Junior Member
Thread Starter
Join Date: Nov 2009
Posts: 10
Default

Originally Posted by dsm1990gsx View Post
Sounds like the timing belt isn't timed right? Also check the basics fuel, compression and spark.
Yes, I think you are right but are their any marks or dots on the block 2 line the cogs up 2? I have never done this type befor, and thanks for the reply.
 
  #4  
Old 11-15-2009, 12:15 PM
dsm1990gsx's Avatar
Super Moderator
Join Date: Oct 2007
Location: Pottstown, Pa
Posts: 4,681
Default

Hope this helps.

Name:  18timingmarks.gif
Views: 6
Size:  4.2 KB
 
  #5  
Old 11-19-2009, 11:55 AM
Junior Member
Thread Starter
Join Date: Nov 2009
Posts: 10
Default

Originally Posted by dsm1990gsx View Post
Hope this helps.

Yes, this did help very much dsm1990gsx and i thank you much , After i found the marks on the block and lined them up it started on the first round. runs great, & that $16 junkyard piston & rings worked great as well but i did knock the glaze out of the clinder wall & also went around the rings with fine emery cloth to deglase aswell . So no smoke , no knocks, all good so thanks again and if i ever need anything elce i know who 2 call on. sam.
 
  #6  
Old 11-19-2009, 12:32 PM
dsm1990gsx's Avatar
Super Moderator
Join Date: Oct 2007
Location: Pottstown, Pa
Posts: 4,681
Default

Glad to help.
 
  #7  
Old 11-19-2009, 12:38 PM
Banned
Join Date: Feb 2006
Location: Austin, TX
Posts: 16,176
Default

Glad we could help!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Mitsued
Mitsubishi Montero & Montero Sport
3
03-23-2012 09:50 PM
X Treme
2nd Generation
5
07-19-2007 03:08 PM
matthew_m75
Mitsubishi Montero & Montero Sport
5
03-21-2007 05:22 PM
racerx55
1st Generation
3
02-17-2007 04:18 AM
madmat
Everything else
3
05-21-2004 01:45 AM


Thread Tools
Search this Thread
Quick Reply: Did I let the belt slip ?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.