Weird Noise when Applying Brakes in Idle Position - Mitsubishi Forum - Mitsubishi Enthusiast Forums

Go Back  Mitsubishi Forum - Mitsubishi Enthusiast Forums > Tech Help and Information > Everything else
Reload this Page >

Weird Noise when Applying Brakes in Idle Position

Everything else Good at troubleshooting? Have a non specific issue that doesnt fit into the other categories?? Ask it here!

Weird Noise when Applying Brakes in Idle Position

Reply

 
 
 
  #1  
Old 12-05-2017, 08:44 PM
Junior Member
Thread Starter
Join Date: Aug 2010
Posts: 2
Exclamation Weird Noise when Applying Brakes in Idle Position

I just purchased 2015 Mitsubishi Outlander Sport ES. Few days have passed and I noticed a weird sound that comes up when brakes are applied to an idle car.

I recorded a video that can be viewed here:
https://drive.google.com/file/d/1OqF...ew?usp=sharing

This sound only comes up when car is in P position and brakes are applied. If car is in any other position (R, N, D, etc.) this sound does not come up.

Any ideas of what could this be? Something with clutch maybe?
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
danthe
Mitsubishi Outlander
5
04-04-2016 12:26 PM
msport_2_outlander
Mitsubishi Outlander
8
01-09-2015 07:30 AM
ravensierra
Mitsubishi Galant
0
12-15-2013 12:01 AM
firstorbit84
Mitsubishi Outlander
9
04-02-2011 06:24 PM
BrunoBoy650
2nd Generation
16
03-23-2007 12:26 PM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory