Belt squeal on a 1600VVT engine. Help please.

  #1  
Old 01-31-2018, 08:28 AM
Todd00000's Avatar
Junior Member
Thread Starter
Join Date: Jan 2018
Location: Costa Rica
Posts: 7
Default Belt squeal on a 1600VVT engine. Help please.

I have a Chinese Brilliance with the Mitsubishi 1600 VVT drive train. I believe this is the "Sirius" engine? Even with a new belt I get a terrible squeal at idle, worse when it's damp. The worst of it goes away after a minute or so, but it's always there. Is this common, is there a fix for this? Thanks.

Todd
 
Attached Thumbnails Belt squeal on a 1600VVT engine. Help please.-brilliance-.jpg  
  #2  
Old 02-01-2018, 11:18 AM
Todd00000's Avatar
Junior Member
Thread Starter
Join Date: Jan 2018
Location: Costa Rica
Posts: 7
Default

Anyone got an idea?
 
  #3  
Old 02-01-2018, 07:27 PM
Todd00000's Avatar
Junior Member
Thread Starter
Join Date: Jan 2018
Location: Costa Rica
Posts: 7
Default

I used soap, a temp fix at best.
 
  #4  
Old 05-01-2018, 03:08 PM
Todd00000's Avatar
Junior Member
Thread Starter
Join Date: Jan 2018
Location: Costa Rica
Posts: 7
Default

We thought the belt tensioner was spring loaded, it's not, it needed to be tightened. Still, the belt squeaks some.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Nrengle
Mitsubishi Outlander
10
04-11-2015 11:16 AM
midgetmurph13
Mitsubishi Galant
3
07-18-2011 02:55 PM
PCB
Mitsubishi Galant
1
11-19-2010 01:52 AM
mack29730
1st Generation
6
07-31-2008 11:48 PM
ibbster
2nd Generation
15
09-25-2007 09:00 AM


Thread Tools
Search this Thread
Quick Reply: Belt squeal on a 1600VVT engine. Help please.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.