2003 diamante ls. P0300 - Mitsubishi Forum - Mitsubishi Enthusiast Forums

Mitsubishi Diamante For the faithful Mitsubishi owner, this car offers high end luxury without high end luxury pricing.

2003 diamante ls. P0300

Reply

 
 
 
  #1  
Old 03-13-2018, 12:52 AM
Junior Member
Thread Starter
Join Date: Mar 2018
Posts: 1
Default 2003 diamante ls. P0300

I have a 03 diamante LS. It's misfiring at idle and it hesitates/misfires upon takeoff but if I get into it it smooths out. Sometimes it runs smooth sometimes it runs like crap. It's throwing p0300 as only code. It has 97k miles
HAS:
New timing belt
New injectors
New plugs, wires, and cap and rotor.
New MAF sensor
New TPS
New New EGR vacuum solenoid
New fuel pump
New fuel filter.

Also, when stopped but in gear it idles around 350-400, but in neutral/park ita at about 700 is this normal? And my fuel gauge is stuck on E, fuel sending unit gone bad? Any help on this would be greatly appreciated.
 

Last edited by Keith Sines; 03-13-2018 at 01:30 AM. Reason: Add stuff
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Captnkitty
Mitsubishi Montero & Montero Sport
1
09-20-2017 11:30 AM
vr4gto
Mitsubishi Galant
8
12-19-2012 09:08 PM
Oranginator91
Mitsubishi Galant
1
10-08-2011 01:16 AM
98gstspy
2nd Generation
15
03-31-2008 07:25 PM
ajav05
Mitsubishi Montero & Montero Sport
3
10-01-2006 03:32 PM


Thread Tools
Search this Thread
Quick Reply: 2003 diamante ls. P0300


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.