Mitsubishi Galant A sporty mid-sized sedan offering the perspective buyer a change from the normal mid-size sedan class.

03 Galant 2.4 Stalling Problems

  #1  
Old 05-14-2013, 11:46 PM
Junior Member
Thread Starter
Join Date: May 2013
Posts: 1
Default 03 Galant 2.4 Stalling Problems

Hey guys new to the forum kind of ran out of ideas so I needed some help to get my car running again. Heres my story few weeks ago on cold start up the motor would rev up to 3k and decrease slowly and when turning on when hot it would idle so low that it would want to die. So I decided to give it a tune and replaced plugs and wires. I also did some research and thought Id clean the MAF sensor and IAC valve with that CRC cleaner which was probably a bad idea. Anyways after the tune up and cleaning I started the car and it blew alot of white smoke probably cause of the cleaner since I sprayed in the throttle body but was idling fine. As soon as I put in reverse it died and kept on trying to die after I started it so my genius thinking altered the idling bolts on top of the intake manifold so it would hold the idle cause I kind of figured I messed up the IAC valve when I cleaned it. That only worked for a couple of days until the car would start and then just die in seconds. I decided to buy a New IAC Valve from Ebay and replaced it and positioned the idle bolts where they used to be. I started the car and it still doesnt want to start and Im completely baffled now. Ive been googling alot and have read that I might have messed up the TP Sensor or the MAF sensor or even the PCM or the PCM needs to be reset not really sure. I would really appreciate some help as this has been driving me mad. Thanks for reading my story and any input

Also if I hold the accelerator pedal down before starting I can get it to run but it runs really bad and tries to die. I also read up on the immobilizer needs to be reprogrammed because I disconnected the battery. Thanks for the help
 
  #2  
Old 05-15-2013, 10:53 AM
Banned
Join Date: Feb 2006
Location: Austin, TX
Posts: 16,176
Default

You most likely destroyed the MAF and TPS.

Check for vac leaks otherwise.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jp2000
Mitsubishi Montero & Montero Sport
2
01-01-2012 05:21 PM
ncmountie
Mitsubishi Galant
2
09-30-2010 09:53 PM
fredij2004
Mitsubishi Galant
9
06-02-2009 02:57 PM
McNeil
2nd Generation
2
05-31-2009 04:46 PM
autorok
Everything else
3
07-01-2005 02:33 PM


Thread Tools
Search this Thread
Quick Reply: 03 Galant 2.4 Stalling Problems


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.