Mitsubishi Galant A sporty mid-sized sedan offering the perspective buyer a change from the normal mid-size sedan class.

Power Gap / Engine is not smooth at any given steady RPM

  #1  
Old 07-04-2007, 06:17 PM
Thread Starter
Join Date: Jul 2007
Posts: 4
Default Power Gap / Engine is not smooth at any given steady RPM

I own a 1998 Galant 2.5 V6. The engine is not smooth at any given steady RPMs. When the car is at any given steady RPM, you can feel an intermitent engine failure. If the car is idle (600 RPM) and i accelerate slowly up to 1800 RPM I experience a power loss and RPMs start going down and up. I don't know how to explain it very well but I'll try.

Imagine that capital "U" is the sound and power of the normal engine operation and that 8 "U" is one second. "u" is a gap in engine sound and power. This is what happens.

"UUUUuUUUUUuUUUUUUUUUUUUUUUUuUUUUUUuUUUUUUuUUUUUUu UUUUUUUUUUUuUuUUUUUUUUUUuUUUUUuUUUUUUUUUUUUUUUUUUu "

I already replaced the Cables, Rotor, Distributor Cap, Spark Plugs, Air Mass Sensor, Fuel Filter, K&N Air Filter, and cleaned the fuel injectors. Can somebody tell me what else can I do?
 
  #2  
Old 07-04-2007, 10:15 PM
Senior Member
Join Date: Oct 2006
Location: Calexico, CA
Posts: 1,832
Default RE: Power Gap / Engine is not smooth at any given steady RPM

do a vacuum test, maybe youre having a vacuum leak somewhere thats causing some probs, which means some hose thats not where it should or some blown or faulty gasket, thats all i can think of right now
 
  #3  
Old 07-05-2007, 12:07 AM
Thread Starter
Join Date: Jul 2007
Posts: 4
Default RE: Power Gap / Engine is not smooth at any given steady RPM

How about a Grounding kit? Would that fix the problem?
 
  #4  
Old 07-05-2007, 06:19 AM
Senior Member
Join Date: Nov 2006
Location: Colorado Springs, CO.
Posts: 3,430
Default RE: Power Gap / Engine is not smooth at any given steady RPM

Check your TPS voltage.
What was the last thing you did to your motor? Why do you think it's eletrical? Do you have a system that causes your lights to dim?
 
  #5  
Old 07-05-2007, 03:08 PM
Thread Starter
Join Date: Jul 2007
Posts: 4
Default RE: Power Gap / Engine is not smooth at any given steady RPM

I replaced the Cables, Rotor, Distributor Cap, Spark Plugs, Changed the Air Mass Sensor, Fuel Filter, K&N Air Filter, and cleaned the fuel injectors. I think its electrical because I have an HID system and sometimes it rapidly blinks once... How can I adjust the TSP voltage and what is the correct voltage it should have?
 
  #6  
Old 07-07-2007, 02:13 PM
Thread Starter
Join Date: Jul 2007
Posts: 4
Default RE: Power Gap / Engine is not smooth at any given steady RPM

Guys the problem has been solved!!! The EGR valve was not fuctioning correctly. It looks like the previous owner fixed something and they did not installed it correctly. I also regulared the TPS voltage and cleaned the Throttle-body. The little electrical problem that it had was that a ground cable had been previously disconected. My 2.5 V6 galant is now running smoother than silk.!!!!

If something new comes up I'll keep you posted. Thanks for everything!

Igor Ruiz
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kreillylaw
Mitsubishi Montero & Montero Sport
6
11-23-2016 04:55 AM
ninjaloops916
Mitsubishi Montero & Montero Sport
2
05-04-2014 04:47 PM
newoutlanderfan
Mitsubishi Outlander
6
12-13-2011 09:01 AM
m3kgt_99
Audio/Visual Electronics
1
08-17-2005 10:13 AM
Mike21
Mitsubishi Lancer and Lancer Sportback
3
12-01-2004 03:14 PM


Thread Tools
Search this Thread
Quick Reply: Power Gap / Engine is not smooth at any given steady RPM


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.