Mitsubishi Galant A sporty mid-sized sedan offering the perspective buyer a change from the normal mid-size sedan class.

Replaced valve cover gasket on my 2.4 (Problems)

  #1  
Old 07-24-2016, 02:31 PM
Junior Member
Thread Starter
Join Date: Nov 2009
Location: Milwaukee, WI
Posts: 5
Default Replaced valve cover gasket on my 2.4 (Problems)

After putting everything back together, I went for a drive. Every time I accelerate it sounds like an airline broke in the shop and the hose is whipping around everywhere. As soon as I lift my foot off accelerator it stops. It idles without the air sound. The reason I changed the gasket was because of the ticking, engine knock that became alot louder. Ended up changing the oil and that seem to quiet everything down. Also when accelerating it feels boggy, like its having problems getting up to speed. I'm sure with the load air is not helping it. Any help would be greatly appreciated.
Thanks..
 
  #2  
Old 12-02-2016, 04:20 PM
Member
Join Date: May 2012
Location: Orlando, Fl
Posts: 39
Default

Check all your venting hoses. Usually there is a hose to goes from the valve cover to the intake hose. Make sure thats connected.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bcolins
Mitsubishi Montero & Montero Sport
15
03-31-2010 11:55 AM
mdoc111
Mitsubishi Montero & Montero Sport
5
04-05-2007 10:51 PM
Natedogg89
2nd Generation
9
02-17-2007 07:49 PM
kyguard22
2nd Generation
2
01-26-2007 03:29 AM
butter03
Mitsubishi Galant
0
03-23-2006 06:10 PM


Thread Tools
Search this Thread
Quick Reply: Replaced valve cover gasket on my 2.4 (Problems)


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.