Mitsubishi Lancer and Lancer Sportback Newer to the United States, the Lancer line offers a sporty compact sedan, with all of the fine styling of the performance minded Evolution.

Idle Problem

  #1  
Old 04-25-2011, 08:54 PM
Junior Member
Thread Starter
Join Date: Apr 2011
Posts: 3
Default Idle Problem

Hi all,

I am having a problem. When the engine is slowly revved up to 1.6k rpm, the rpm will automatically go back down to 1.0k rpm. Problem does not exist when engine is quickly revved or when aircon is turned on.

When that occurs, the TPS sensor output seems to be stuck at 0.6V (the voltage should come down to ~0.5V when idling at 1.0k rpm).

I have cleaned the TB and checked the hoses. No problem with the ISC or TPS as i have changed it several times and it is still the same symptom.

Any ideas what is going on ?
 
  #2  
Old 05-06-2011, 06:43 AM
mxmikie's Avatar
Senior Member
Join Date: Sep 2005
Location: Bouse,az
Posts: 1,059
Default

did you replace the o-ring on the biss screw ????
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
yamahablaster8230
2nd Generation
2
08-29-2006 09:28 AM
RCJr9186
2nd Generation
8
01-02-2006 06:32 PM
rbland
Everything else
4
10-07-2004 04:16 AM
VR4Restored
Mitsubishi Galant
1
08-14-2004 01:09 AM
1rippinGT
Mitsubishi 3000GT
4
03-24-2004 01:38 PM


Thread Tools
Search this Thread
Quick Reply: Idle Problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.