I'm stumped are you smarter then me - Mitsubishi Forum - Mitsubishi Enthusiast Forums


Mitsubishi Mirage This sport compact offers economy without compromising comfort.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-10-2018, 03:39 AM
Junior Member
Thread Starter
 
Join Date: Apr 2018
Posts: 4
Default I'm stumped replaced everything just about

Well I have a 1997 mirage 5 speed 1.5 btw I went 7 pages in the forums and used the search

it start runs weak I can get up to highway speeds but it takes forever I get no power at wot in any gear.

I had bad plugs about 1500 miles ago so I replaced them gapped out to .42.
checked plugs looked good

replaced cap and rotor on the distubuter no change

checked spark plug wires and injectors while it ran by removing each one all fine

checked vacuum lines for leaks didn't find any replaced a few lines no fix DID NOTICE WHEN I TOOK OFF THE VACUUM LINE ON THE FUEL RAIL AND INTAKE MANIFOLD I WAS ABLE TO TEST DRIVE AND IT HAD FULL POWER FOR ONE PULL COULD NOT replicate

changed fuel filter no change

checked cat after driving home today wasn't red hot or anything

I have a vacuum tester but honestly don't know how to use it and I'm also not getting a cel

thanks for reading any advice would be appreciated

Last edited by Bigchief; 04-13-2018 at 11:04 AM.
Reply With Quote
  #2  
Old 04-10-2018, 01:22 PM
Junior Member
Thread Starter
 
Join Date: Apr 2018
Posts: 4
Default

So I just went for a test drive and decided to unplug the tps sensor and noticed no difference so I think I found the culprit also the gas mileage has been complete ****
Reply With Quote
  #3  
Old 04-12-2018, 01:46 AM
Junior Member
Thread Starter
 
Join Date: Apr 2018
Posts: 4
Default

I've now changed the plugs and wires again cut the cat off but before this the car is a complete turd and won't get up to any sort of speed and when starting it after it started I could hold my foot to the floor for 30 secs before it started to even rev up
Reply With Quote
  #4  
Old 04-13-2018, 11:05 AM
Junior Member
Thread Starter
 
Join Date: Apr 2018
Posts: 4
Default

I've changed the distributor now and won't move under load and still can't rev it
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need someone smarter than I Erictaylor Off Topic 1 03-12-2017 01:43 AM
Strange engine noise on cold start and then when changing gear, then it goes away ! gormleyp Mitsubishi Outlander 3 02-05-2015 03:34 AM
Can anybody help me? Totaly stumped on this... master_disaster Mitsubishi Lancer and Lancer Sportback 4 03-19-2008 09:44 PM
runs then dies then no spark rexbd Mitsubishi 3000GT 19 01-29-2008 07:18 PM
STUMPED!! RCJr9186 2nd Generation 10 01-20-2007 07:49 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 10:27 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.