1st Generation This includes all Eclipses, Talons, and Lasers built from 1990-1994.

please help (newbie)

  #1  
Old 02-27-2008, 03:26 PM
Thread Starter
Join Date: Feb 2008
Posts: 2
Default please help (newbie)

hey. first off, im new. i have a 1990 eclise gs turbo. the problem is, it wont hold a steady idle. when you rev it up to 2000 rpms or more and try to hold it, it revs up then cuts out. it wont stay there. i have replaced the plugs, wires, fuel filter, ignition control mod, coil pak, air flow meter, and cleaned the injectors. nothing works. any suggestions?
 
  #2  
Old 02-27-2008, 04:46 PM
Rob
Rob is offline
Banned
Join Date: Jan 2008
Posts: 866
Default RE: please help (newbie)

Have you checked all vacuum hoses for leaks, cracks, or breaks?
 
  #3  
Old 02-27-2008, 07:13 PM
Super Moderator
Join Date: Jan 2006
Location:
Posts: 11,758
Default RE: please help (newbie)

usually it will have to do with the ISC motor but i would start with the vacuum lines. Also check out www.vfaq.com for a write-up on the fluctuating idle faq
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
enzo_hashmat2006
Everything else
11
10-10-2017 05:46 PM
Ninjobitch
Mitsubishi Montero & Montero Sport
3
08-21-2013 12:35 AM
ukiltmybrutha
Mitsubishi Montero & Montero Sport
3
06-19-2011 03:06 PM
tiller801
1st Generation
5
02-14-2008 10:25 PM
roberttkim
2nd Generation
17
12-25-2004 12:53 AM


Thread Tools
Search this Thread
Quick Reply: please help (newbie)


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.